MantisBT - Piwigo
View Issue Details
0001210Piwigoweb APIpublic2009.10.26 01:532009.12.04 23:02
plg 
plg 
highblockalways
closedfixed 
2.0.5 
2.0.72.0.7 
any
Apache 1.3.x
0001210: [pwg.images.add] failure if memory_get_usage function is not available
As described in topic:15449 the function memory_get_usage may not exists depending on the PHP version and compiling options.

We have to check for its availability before using it (the script should fall back nicely if function is not available)
No tags attached.
Issue History
2009.10.26 01:53plgNew Issue
2009.10.26 01:53plgStatusnew => assigned
2009.10.26 01:53plgAssigned To => plg
2009.10.26 01:53plgbrowser => any
2009.10.26 01:53plgWeb server => Apache 1.3.x
2009.11.06 00:19plgTarget Version2.0.6 => 2.0.7
2009.12.04 22:54svnCheckin
2009.12.04 22:54svnNote Added: 0003175
2009.12.04 22:57svnCheckin
2009.12.04 22:57svnNote Added: 0003176
2009.12.04 23:02plgNote Added: 0003177
2009.12.04 23:02plgStatusassigned => closed
2009.12.04 23:02plgResolutionopen => fixed
2009.12.04 23:02plgFixed in Version => 2.0.7

Notes
(0003175)
svn   
2009.12.04 22:54   
[Subversion] r4424 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
bug 1210 fixed: check if the memory_get_usage function is available before
using it.
(0003176)
svn   
2009.12.04 22:57   
[Subversion] r4425 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r4424 from branch 2.0 to trunk

bug 1210 fixed: check if the memory_get_usage function is available before
using it.
(0003177)
plg   
2009.12.04 23:02   
In my php.ini, I've added a:

disable_functions = memory_get_usage

In the ws_log_file, the following lines:

[2009-12-04T22:35:34+01:00] [merge_chunks] memory_get_usage before loading chunks: 4029176
[2009-12-04T22:35:34+01:00] [merge_chunks] memory_get_usage on chunk 1: 4216760
[2009-12-04T22:35:34+01:00] [merge_chunks] memory_get_usage after loading chunks: 4216896

are simply not available any more.