MantisBT - Piwigo
View Issue Details
0001742Piwigouploadpublic2010.06.23 12:422010.06.29 02:27
admin 
plg 
normalmajoralways
closedfixed 
2.1.0 
2.1.22.1.2 
any
Apache 1.3.x
0001742: upload fails if EXIF functions are missing
As discussed on http://piwigo.org/forum/viewtopic.php?id=16144 [^] with the default configuration, if the EXIF functions are missing, then the whole upload fails.

I propose:

1) a warning message saying that EXIF functions are missing
2) a piece of code to avoid trying to read the EXIF metadata if the EXIF functions are disabled
No tags attached.
Issue History
2010.06.23 12:42adminNew Issue
2010.06.23 12:42adminStatusnew => assigned
2010.06.23 12:42adminAssigned To => plg
2010.06.23 12:42adminbrowser => any
2010.06.23 12:42adminWeb server => Apache 1.3.x
2010.06.29 02:18svnCheckin
2010.06.29 02:18svnNote Added: 0004014
2010.06.29 02:26svnCheckin
2010.06.29 02:26svnNote Added: 0004015
2010.06.29 02:27plgStatusassigned => closed
2010.06.29 02:27plgResolutionopen => fixed
2010.06.29 02:27plgFixed in Version => 2.1.2

Notes
(0004014)
svn   
2010.06.29 02:18   
[Subversion] r6621 by plg on branch 2.1

-----[Subversion commit log]----------------------------------------------------
bug 1742 fixed: if the EXIF functions are not available:

1) display a warning (but not an error)
2) avoid to try to read EXIF data
(0004015)
svn   
2010.06.29 02:26   
[Subversion] r6622 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r6621 from branch 2.1 to trunk

bug 1742 fixed: if the EXIF functions are not available:

1) display a warning (but not an error)
2) avoid to try to read EXIF data