MantisBT - Piwigo
View Issue Details
0001754Piwigodatabasepublic2010.07.01 21:192010.07.03 14:17
nikrou 
nikrou 
normalmajoralways
closedfixed 
2.1.2 
2.1.32.1.3 
any
PostgreSQL (version < 8.4)
Apache 1.3.x
0001754: The keyword AS is mandatory for alias in POstgreSQL queries
We decided that the required version of PostreSQL need to be at least 8.0. But before release 8.4 AS keyword is mandatory for alias in select fields.

Ex: "select cat.id AS cat_id ..." and not "select cat.id cat_id ..."
No tags attached.
Issue History
2010.07.01 21:19nikrouNew Issue
2010.07.01 21:19nikrouStatusnew => assigned
2010.07.01 21:19nikrouAssigned To => nikrou
2010.07.01 21:19nikroubrowser => any
2010.07.01 21:19nikrouDatabase engine and version => PostgreSQL (version < 8.4)
2010.07.01 21:19nikrouWeb server => Apache 1.3.x
2010.07.03 14:12svnCheckin
2010.07.03 14:12svnNote Added: 0004018
2010.07.03 14:16svnCheckin
2010.07.03 14:16svnNote Added: 0004019
2010.07.03 14:17nikrouStatusassigned => closed
2010.07.03 14:17nikrouResolutionopen => fixed
2010.07.03 14:17nikrouFixed in Version => 2.1.3

Notes
(0004018)
svn   
2010.07.03 14:12   
[Subversion] r6652 by nikrou on trunk

-----[Subversion commit log]----------------------------------------------------
Bug 1754 fixed : The keyword AS is mandatory for alias in PostgreSQL queries
(0004019)
svn   
2010.07.03 14:16   
[Subversion] r6653 by nikrou on branch 2.1

-----[Subversion commit log]----------------------------------------------------
Bug 1754 fixed : The keyword AS is mandatory for alias in PostgreSQL queries
Merge from trunk