MantisBT - Piwigo
View Issue Details
0002003Piwigoweb APIpublic2010.11.03 23:192010.11.03 23:26
plg 
plg 
normalminorrandom
closedfixed 
2.1.4 
2.1.52.1.5 
any
Apache 1.3.x
0002003: [pwg.images.setInfo] randomly fails on calling invalidate_user_cache
The Lightroom publish to Piwigo plugin developer has reported that sometimes he received :

Fatal error: Call to undefined function invalidate_user_cache() in .../include/ws_functions.inc.php on line 1917

when calling pwg.images.setInfo with parameters:

* image_id = 111
* categories= 34;35
I can't reproduce
No tags attached.
Issue History
2010.11.03 23:19plgNew Issue
2010.11.03 23:19plgStatusnew => assigned
2010.11.03 23:19plgAssigned To => plg
2010.11.03 23:19plgbrowser => any
2010.11.03 23:19plgWeb server => Apache 1.3.x
2010.11.03 23:23svnCheckin
2010.11.03 23:23svnNote Added: 0004460
2010.11.03 23:24svnCheckin
2010.11.03 23:24svnNote Added: 0004461
2010.11.03 23:26plgStatusassigned => closed
2010.11.03 23:26plgResolutionopen => fixed
2010.11.03 23:26plgFixed in Version => 2.1.5

Notes
(0004460)
svn   
2010.11.03 23:23   
[Subversion] r7612 by plg on branch 2.1

-----[Subversion commit log]----------------------------------------------------
bug 2003 fixed: random failure on calling invalidate_user_cache. I move the
include of admin functions outside conditional blocks, even if we should also
enter the first block.
(0004461)
svn   
2010.11.03 23:24   
[Subversion] r7613 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r7612 from branch 2.1 to trunk

bug 2003 fixed: random failure on calling invalidate_user_cache. I move the
include of admin functions outside conditional blocks, even if we should also
enter the first block.