MantisBT - Piwigo
View Issue Details
0002677Piwigoinstallation & upgradepublic2012.07.03 00:262012.07.03 00:29
plg 
plg 
normalfeatureN/A
closedfixed 
2.4.0 
2.4.12.4.1 
any
Apache 1.3.x
0002677: smarter check of the current version and required upgrade
With upgrade from 2.3, if the upgrade fails at some point, you may have added column images.coi BUT not updated config[param=piwigo_db_version]. Then include/common.inc.php will redirect you to upgrade.php which says that no upgrade is required (because you have column images.coi).
No tags attached.
Issue History
2012.07.03 00:26plgNew Issue
2012.07.03 00:26plgStatusnew => assigned
2012.07.03 00:26plgAssigned To => plg
2012.07.03 00:26plgbrowser => any
2012.07.03 00:26plgWeb server => Apache 1.3.x
2012.07.03 00:28svnCheckin
2012.07.03 00:28svnNote Added: 0006419
2012.07.03 00:28svnCheckin
2012.07.03 00:28svnNote Added: 0006420
2012.07.03 00:29plgStatusassigned => closed
2012.07.03 00:29plgResolutionopen => fixed
2012.07.03 00:29plgFixed in Version => 2.4.1

Notes
(0006419)
svn   
2012.07.03 00:28   
[Subversion] r16312 by plg on branch 2.4

-----[Subversion commit log]----------------------------------------------------
bug 2677 fixed: smarter check of the database version and manage partial upgrade.
(0006420)
svn   
2012.07.03 00:28   
[Subversion] r16313 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r16312 from branch 2.4 to trunk

bug 2677 fixed: smarter check of the database version and manage partial upgrade.