MantisBT - Piwigo
View Issue Details
0002698Piwigoalbumspublic2012.07.16 15:212012.07.19 10:51
Goulou 
flop25 
normalminoralways
closedfixed 
FirefoxLinuxFedora 17 x86_64
2.4.1 
2.4.2 
Mozilla
Apache 1.3.x
0002698: When hitting "return" in name field (album creation), the album does not get created.
When I hit return in the name field (instead of clicking the "Create" button), the album does not get created.
Instead, the page reloads and the message "L'ordre manuel des albums a été sauvegardé" shows up on top of page. (=Manual order of albums has been saved)
In administration, go to "Administer sub albums" of any albums.
Click "create a new album"
Enter any album name
Hit enter
Clicking "Create" works fine, but this is annoying...
No tags attached.
png localhost screen capture 2012-7-18-17-31-39.png (54,058) 2012.07.18 17:33
http://piwigo.org/bugs/file_download.php?file_id=145&type=bug
png

png localhost screen capture 2012-7-18-17-31-47.png (57,709) 2012.07.18 17:33
http://piwigo.org/bugs/file_download.php?file_id=146&type=bug
png
Issue History
2012.07.16 15:21GoulouNew Issue
2012.07.16 15:21Gouloubrowser => Mozilla
2012.07.16 15:21GoulouWeb server => Apache 1.3.x
2012.07.18 16:27flop25Statusnew => assigned
2012.07.18 16:27flop25Assigned To => flop25
2012.07.18 16:33svnCheckin
2012.07.18 16:33svnNote Added: 0006482
2012.07.18 16:35svnCheckin
2012.07.18 16:35svnNote Added: 0006483
2012.07.18 17:33plgFile Added: localhost screen capture 2012-7-18-17-31-39.png
2012.07.18 17:33plgFile Added: localhost screen capture 2012-7-18-17-31-47.png
2012.07.18 17:33plgNote Added: 0006485
2012.07.18 17:36plgNote Added: 0006486
2012.07.18 18:19svnCheckin
2012.07.18 18:19svnNote Added: 0006487
2012.07.18 18:23svnCheckin
2012.07.18 18:23svnNote Added: 0006488
2012.07.18 18:29plgNote Added: 0006489
2012.07.18 18:35svnCheckin
2012.07.18 18:35svnNote Added: 0006490
2012.07.18 18:37svnCheckin
2012.07.18 18:37svnNote Added: 0006491
2012.07.18 18:37flop25Note Added: 0006492
2012.07.18 19:26plgNote Added: 0006493
2012.07.19 10:51flop25Statusassigned => closed
2012.07.19 10:51flop25Resolutionopen => fixed
2012.07.19 10:51flop25Fixed in Version => 2.4.2

Notes
(0006482)
svn   
2012.07.18 16:33   
[Subversion] r16825 by flop25 on trunk

-----[Subversion commit log]----------------------------------------------------
bug:2698
moving the forms
(0006483)
svn   
2012.07.18 16:35   
[Subversion] r16826 by flop25 on branch 2.4

-----[Subversion commit log]----------------------------------------------------
merge r16825 from trunk to 2.4 branch
bug:2698
moving the forms
(0006485)
plg   
2012.07.18 17:33   
On Linux Firefox 14, the display is completely modified compared to 2.4.1. And it's not "better at all", see my screenshots.
(0006486)
plg   
2012.07.18 17:36   
Behavior is identical on Chromium.
(0006487)
svn   
2012.07.18 18:19   
[Subversion] r16827 by flop25 on trunk

-----[Subversion commit log]----------------------------------------------------
bug:2698
2 id identical
fieldset instead of a span
moving up the field for autoorder
hiding the link to set a autoorder if there is no album (clicking on it didn't do anything)
(0006488)
svn   
2012.07.18 18:23   
[Subversion] r16828 by flop25 on branch 2.4

-----[Subversion commit log]----------------------------------------------------
merge r16827 from trunk to 2.4 branch
bug:2698
2 id identical
fieldset instead of a span
moving up the field for autoorder
hiding the link to set a autoorder if there is no album (clicking on it didn't do anything)merge r16825
(0006489)
plg   
2012.07.18 18:29   
OK, better with [Subversion] r16828. Now can we display the 2 links " create a new album | apply automatic sort order" *before* the associated fieldsets? (just like in 2.4.1). The bug is about the behavior of the Enter key, not about the position of the fieldsets.
(0006490)
svn   
2012.07.18 18:35   
[Subversion] r16829 by flop25 on trunk

-----[Subversion commit log]----------------------------------------------------
bug:2698
at the bottom!
(0006491)
svn   
2012.07.18 18:37   
[Subversion] r16830 by flop25 on branch 2.4

-----[Subversion commit log]----------------------------------------------------
merge r16829 from trunk to 2.4
bug:2698
at the bottom!
(0006492)
flop25   
2012.07.18 18:37   
better sir?
(0006493)
plg   
2012.07.18 19:26   
> better sir?

Yes, back to the same behavior as in 2.4.1 (I wonder why you changed it, really...)