MantisBT - Piwigo
View Issue Details
0003025Piwigootherpublic2014.01.18 16:142014.01.18 16:18
mistic100 
mistic100 
normalminorhave not tried
closedfixed 
PHP < 5.3
2.6.0 
2.6.12.6.1 
any
Apache 1.3.x
0003025: Fatal error: Declaration of Calendar::get_date_where() must be compatible with that of CalendarBase::get_date_where()
PHP 5.3 is more permissive with method signatures of abstract classes....
No tags attached.
Issue History
2014.01.18 16:14mistic100New Issue
2014.01.18 16:14mistic100Statusnew => assigned
2014.01.18 16:14mistic100Assigned To => mistic100
2014.01.18 16:14mistic100browser => any
2014.01.18 16:14mistic100Web server => Apache 1.3.x
2014.01.18 16:15svnCheckin
2014.01.18 16:15svnNote Added: 0007318
2014.01.18 16:17svnCheckin
2014.01.18 16:17svnNote Added: 0007319
2014.01.18 16:18mistic100Statusassigned => closed
2014.01.18 16:18mistic100Resolutionopen => fixed
2014.01.18 16:18mistic100Fixed in Version => 2.6.1

Notes
(0007318)
svn   
2014.01.18 16:15   
[Subversion] r26865 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
bug 3025: Fatal error: Declaration of Calendar::get_date_where() must be compatible with that of CalendarBase::get_date_where()
(0007319)
svn   
2014.01.18 16:17   
[Subversion] r26866 by mistic100 on branch 2.6

-----[Subversion commit log]----------------------------------------------------
Merged revision(s) r26865 from trunk:
bug 3025: Fatal error: Declaration of Calendar::get_date_where() must be compatible with that of CalendarBase::get_date_where()