Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001022 [Piwigo] albums major always 2009.06.01 23:23 2009.06.02 22:23
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.3 Product Version 2.0.2
  Target Version 2.0.3 Product Build
Summary 0001022: No more categories when removing all category associations from a photo
Description With pLoader I have no more physical categories. So while managing categories associated to a given photo, you might remove all associations, and the error occur:


Warning: [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 3

SELECT id,name,uppercats,global_rank
  FROM categories
  WHERE id NOT IN ()
; in include/functions.inc.php on line 918

Then I see no categories to associate the photo to (and this is a problem).

I have a workaround, because I can associate some categories from the bulk manager.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0002631)
plg (manager)
2009.06.02 22:23

fixed on branch 2.0 in [Subversion] r3389
merged on trunk Colibri in [Subversion] r3390

- Issue History
Date Modified Username Field Change
2009.06.01 23:23 plg New Issue
2009.06.01 23:23 plg Status new => assigned
2009.06.01 23:23 plg Assigned To => plg
2009.06.01 23:23 plg browser => any
2009.06.01 23:23 plg Web server => Apache 1.3.x
2009.06.02 22:23 plg Note Added: 0002631
2009.06.02 22:23 plg Status assigned => closed
2009.06.02 22:23 plg Resolution open => fixed
2009.06.02 22:23 plg Fixed in Version => 2.0.3


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker