Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000104 [Piwigo] search minor N/A 2005.04.26 09:10 2006.04.12 12:39
Reporter vimages View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6 branch Product Version 1.4.0
  Target Version Product Build
Summary 0000104: # caracter in search engine
Description is it possible to enable # and use it.

For exemple I add <#>12 or <#>005 in the IPTC keywords of a picture, <#>52 for another picture etc...

After, I want to use <#>.. in the search engine. for exemple, I write <#>52 and the search engine find the picture.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
related to 0000101closedplg problem with IE search on keywords 

-  Notes
(0000118)
plg (manager)
2005.04.27 19:47

I've updated the description with '<>' around # character because a # followed by some digits is considered by mantis as the id of a bug and transformed into the html link to this issue...
(0000123)
plg (manager)
2005.04.30 15:30

This issue is not a feature, but a bug. I've updated the severity.
(0000124)
plg (manager)
2005.04.30 17:08

I've worked a couple of hours on your problem and my conclusion is the following : the actual method of passing $_GET['search'] forbids the use of many characters :-/ It's not possible to solve this properly with the actual method.

The problem comes from design. I've just started to think about a new method for passing safely the "search string" between pages. It comes from inspiration of other tools... I will soon create a wiki article and discussion in forum about the new technical design of search feature. (in french certainly)

This problem can't be solved on branch 1.4. You'll have to wait for branch 1.5

I will add a note to this issue to inform about the discussion start.
(0000739)
plg (manager)
2006.04.12 12:39

Searching "#" in the author name or picture name will be possible on branch 1.6 due to redesign of search engine backend.

- Issue History
Date Modified Username Field Change
2005.04.26 09:10 vimages New Issue
2005.04.26 09:10 vimages browser => any
2005.04.26 09:10 vimages Web server => Apache 1.3.x
2005.04.26 11:38 gweltas Status new => assigned
2005.04.26 11:38 gweltas Assigned To => plg
2005.04.27 19:43 plg Description Updated
2005.04.27 19:47 plg Note Added: 0000118
2005.04.27 19:47 plg Description Updated
2005.04.30 15:30 plg Note Added: 0000123
2005.04.30 15:30 plg Severity feature => minor
2005.04.30 15:30 plg Category other => search
2005.04.30 17:08 plg Note Added: 0000124
2005.04.30 17:09 plg Relationship added related to 0000101
2006.04.12 12:39 plg Note Added: 0000739
2006.04.12 12:39 plg Status assigned => closed
2006.04.12 12:39 plg Resolution open => fixed
2006.04.12 12:39 plg Fixed in Version => 1.6 branch


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker