Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000118 [Piwigo] display feature always 2005.05.20 16:27 2009.08.10 23:46
Reporter xaviounet View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.0 Product Version
  Target Version Product Build
Summary 0000118: Personalisation of the presentation
Description My second suggestion=>
A lot of people ask for features to improve page presentation. Maybe you could add a feature in the administration section allowing to add text (in a frame or not) above or under the thumbnails in each page (index, category, sub-category), to change order of categories (special, login, links, sommaire) in the left menu, with possibilities to add a link, to add a category, to delete a category in this menu. Maybe also something like a wysiwyg interface to add commentaries. Also I don't know if it is already possible to change the order of photos or category increments, but it would be good to have the possibility to add new images at the end instead of the beginning for example.

Hope it's not too much in the same request, but I think all this goes together...
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0000153)
plg (manager)
2005.05.22 14:49

What you ask is quite huge, let's try to answer. This is my voice, maybe Gweltas or Sephi don't share the same point of view...

> allowing to add text (in a frame or not) above or under
> the thumbnails in each page (index, category, sub-category)

If you mean a text depending on the category, what about category description? This feature exists since the beginning of PhpWebGallery.

If you mean an introducing text for the whole gallery, what about simply modifying template/*/header.tpl ? (yes, I know the answer : it is painful to modify for each template...)

I think it would be nice to add the ability to set :

- a title to the gallery (displayed where the PhpWebGallery logo is in template "default" and also in the HTML title)

- a descriptive message displayed just behind the title.

Those two informations would be managed by the template as they wish...

Would this suit you? (that would suit me ;-)

> to change order of categories (special, login, links,
> sommaire) in the left menu, with possibilities to add
> a link, to add a category, to delete a category in this
> menu.

This would be possible, but a lot of work for quite a useless feature :-/ This would be possible in branch 1.4 because links of menu "Special" are send by category.php, not managed in template/*/category.tpl, but Gweltas would like to move a part of links management into template/*/category.tpl. In consequence, it would be impossible to set items order without modifying the template. I must admit I agree with Gweltas point of view.

Please, remember that PhpWebGallery is only a picture gallery presentation tool, not an integrated portal. Personnaly, I do not approve adding such features.

> Maybe also something like a wysiwyg interface to add
> commentaries.

Wow! Completely out of question. Do you want to make PhpWebGallery become "une usine à gaz" (big software which is able to do everything and which is unmaintainable) ?

It would be nice to provide a help to users telling them they can make their words /italic/, *bold*, _underlined_, but I don't want to go further. Users comments are only a feature of PhpWebGallery, not the main feature.

My note sounds quite like a "no" to your requests, I'm sorry but you don't have the same idea of the software as mine :-/

PS : this issue could also have been divided in 3 issues at least. Remember : creating a new issue costs nothing ;-)
(0000160)
xaviounet (reporter)
2005.05.22 21:29

Ok I totally agree with your suggestions for the first request.
And as I understand better your position for the software now I have no problems with your last answers.
thanks a lot
(0000173)
plg (manager)
2005.06.25 17:22

On the development branch (BSF), I've just added a feature that let you add links in a dedicated box of the main page : https://mail.gna.org/public/phpwebgallery-cvs/2005-06/msg00006.html [^]
(0002813)
mathiasm (manager)
2009.08.10 23:46

Fixed by plugins and all improvements since 1.5

- Issue History
Date Modified Username Field Change
2005.05.20 16:27 xaviounet New Issue
2005.05.20 16:27 xaviounet browser => any
2005.05.20 16:27 xaviounet Web server => Apache 1.3.x
2005.05.22 14:49 plg Note Added: 0000153
2005.05.22 14:49 plg Assigned To => plg
2005.05.22 14:49 plg Status new => assigned
2005.05.22 14:49 plg version 1.4.0 =>
2005.05.22 15:45 plg Category user comments => display
2005.05.22 21:29 xaviounet Note Added: 0000160
2005.06.25 17:22 plg Note Added: 0000173
2009.08.10 23:46 mathiasm Note Added: 0002813
2009.08.10 23:46 mathiasm Status assigned => closed
2009.08.10 23:46 mathiasm Resolution open => fixed
2009.08.10 23:46 mathiasm Fixed in Version => 2.0.0


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker