Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000125 [Piwigo] display feature always 2005.06.29 20:59 2006.02.04 12:38
Reporter tieum View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6 branch Product Version
  Target Version Product Build
Summary 0000125: Images sort order
Description Would it be possible to have a choice for images sort order.

Right now it is sorted from more recent to older in each category.

It would be nice to have:

* recent to old
* old to recent
* filename
* .... (any suggestion)
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
has duplicate 0000280closedrvelices Allow visitors/users to choose image ordering inside a category 
related to 0000169closedplg trier les images d'une cat├ęgorie 

-  Notes
(0000184)
plg (manager)
2005.06.29 21:52

Did you take a look at configuration parameter $conf['order_by'] in include/config.inc.php? Isn't it enough for your needs?
(0000185)
tieum (reporter)
2005.06.29 22:26

Since I am not the admin at my site, an SQL parameter would be better.
(0000308)
plg (manager)
2005.10.19 22:30

OK, would you need the sort order to be different in each category or a global parameter would be enough?

The limitation with a "GUI" configuration parameter compared to a "file" configuration parameter is that you can't combine: "order by FILE asc, DATE_CREATION desc".
(0000311)
tieum (reporter)
2005.10.20 07:54

For my use a global parameter would be enough.
(0000608)
plg (manager)
2006.02.04 12:38

request closed. See 0000280 which is a duplicate of this one.

- Issue History
Date Modified Username Field Change
2005.06.29 20:59 tieum New Issue
2005.06.29 20:59 tieum browser => any
2005.06.29 20:59 tieum Web server => Apache 1.3.x
2005.06.29 21:00 tieum Issue Monitored: tieum
2005.06.29 21:52 plg Note Added: 0000184
2005.06.29 22:26 tieum Note Added: 0000185
2005.10.19 22:24 plg Relationship added related to 0000169
2005.10.19 22:30 plg Note Added: 0000308
2005.10.19 22:30 plg Assigned To => plg
2005.10.19 22:30 plg Status new => assigned
2005.10.19 22:30 plg version 1.3.4 =>
2005.10.19 22:30 plg Status assigned => feedback
2005.10.20 07:54 tieum Note Added: 0000311
2005.10.20 11:17 plg Status feedback => acknowledged
2006.02.04 12:37 plg Relationship added has duplicate 0000280
2006.02.04 12:38 plg Note Added: 0000608
2006.02.04 12:38 plg Status acknowledged => closed
2006.02.04 12:38 plg Resolution open => fixed
2006.02.04 12:38 plg Fixed in Version => 1.6 branch


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker