Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001314 [Piwigo] installation & upgrade minor always 2009.12.09 10:43 2010.04.14 17:42
Reporter Dsls View Status public  
Assigned To nikrou
Priority normal Resolution fixed Platform Wamp 2.0i, php 5.3, apache 2.2
Status closed   OS Windows
Projection none   OS Version Vista
ETA none Fixed in Version 2.1.0RC1 Product Version
  Target Version Product Build (SVN trunk, revision 4453)
Summary 0001314: PHP notices and warning after last install step.
Description At the last installation step, just after submitting database parameters, where the page displays "Les param├Ętres entr├ęs sont corrects" (sorry, french install...), there are some PHP notices and warnings on the page :

Notice: Undefined variable: step in C:\wamp\www\piwigo\install.php on line 200

Notice: Undefined index: dblayer in C:\wamp\www\piwigo\install.php on line 230

Warning: constant() [<a href='function.constant'>function.constant</a>]: Couldn't find constant REQUIRED__VERSION in C:\wamp\www\piwigo\install.php on line 230


That may be linked to svn version (vs release version which could process some additional operations, such as constants definitions), though ...
Steps To Reproduce Install piwigo on a NOTICE enabled environment, under Wamp, from SVN trunk, and proceed normal steps
Additional Information
Tags No tags attached.
browser any
Database engine and version 5
PHP version 5.3
Web server Apache 2.2
Attached Files

- Relationships

-  Notes
(0003205)
svn (reporter)
2009.12.09 20:20

[Subversion] r4454 by nikrou on trunk

-----[Subversion commit log]----------------------------------------------------
Bug 1314 : warning because of undefined variables in installation
(0003206)
nikrou (developer)
2009.12.09 20:26

[Subversion] r4454

- Issue History
Date Modified Username Field Change
2009.12.09 10:43 Dsls New Issue
2009.12.09 10:43 Dsls browser => any
2009.12.09 10:43 Dsls MySQL version => 5
2009.12.09 10:43 Dsls PHP version => 5.3
2009.12.09 10:43 Dsls Web server => Apache 2.2
2009.12.09 10:59 ddtddt Status new => assigned
2009.12.09 10:59 ddtddt Assigned To => nikrou
2009.12.09 20:20 svn Checkin
2009.12.09 20:20 svn Note Added: 0003205
2009.12.09 20:26 nikrou Note Added: 0003206
2009.12.09 20:26 nikrou Status assigned => resolved
2009.12.09 20:26 nikrou Resolution open => fixed
2010.04.14 17:42 plg Status resolved => closed
2010.04.14 17:42 plg Fixed in Version => 2.1.0RC1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker