Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000133 [Piwigo] users & groups feature always 2005.08.07 16:02 2005.08.18 21:42
Reporter chrisaga View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.4.2 Product Version 1.4.1
  Target Version Product Build
Summary 0000133: Deleting user favorites is too restrictive
Description When a picture belongs to a category for which a user hace no autorization, it is deleted from His favorites.

It makes the favorites mostly unusable when, for instance, the images are stored in directories but users can only see them in virtual galleries (it makes gallery management easyer for me).

The same thing happens when pictures belongs to several private galleries. Only people with rigth on all the galleries can use favorites.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0000199)
plg (manager)
2005.08.07 18:09

Bug corrected. Copy/paste of the CVS commit message :

> - bug 133 corrected : Deleting user favorites is too restrictive. Instead of
> deleting a favorite because it belongs to at least one forbidden category,
> a favorite is deleted if it belongs to no authorized category (which was
> the expected behaviour).

See the diff on the single modified file : http://cvs.gna.org/viewcvs/phpwebgallery/phpwebgallery/include/functions_user.inc.php.diff?r1=1.37&r2=1.37.2.1 [^]

This correction will be present in release 1.4.2 (which is not roadmaped yet), do the modification by yourself if you want it earlier.
(0000214)
plg (manager)
2005.08.18 21:42

Correction reported on branch BSF : http://cvs.gna.org/viewcvs/phpwebgallery/phpwebgallery/include/functions_user.inc.php.diff?r1=text&tr1=1.41&r2=text&tr2=1.42&diff_format=u [^]

(the report closes the entry)

- Issue History
Date Modified Username Field Change
2005.08.07 16:02 chrisaga New Issue
2005.08.07 16:02 chrisaga browser => any
2005.08.07 16:02 chrisaga Web server => Apache 1.3.x
2005.08.07 18:09 plg Note Added: 0000199
2005.08.07 18:09 plg Assigned To => plg
2005.08.07 18:09 plg Status new => resolved
2005.08.07 18:09 plg Resolution open => fixed
2005.08.07 18:09 plg Fixed in Version => 1.4.2
2005.08.18 21:42 plg Note Added: 0000214
2005.08.18 21:42 plg Status resolved => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker