Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001374 [Piwigo] language feature N/A 2010.01.09 20:33 2010.01.26 10:41
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.8 Product Version
  Target Version 2.0.8 Product Build
Summary 0001374: script to detect missing translations
Description In post:109758 I suggested to never use the "/* TODO */" method in language files anymore.

We need a simple script to detect the missing translations.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0003314)
svn (reporter)
2010.01.09 20:35

[Subversion] r4636 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
feature 1374: removed the "/* TODO */" in language files, the script to detect
missing translations will come in a distinct commit.
(0003315)
svn (reporter)
2010.01.09 20:37

[Subversion] r4637 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
feature 1374; first version of the script to detect missing translations. It
is very basic with an ugly output. It just does the job.
(0003316)
svn (reporter)
2010.01.09 21:54

[Subversion] r4638 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
feature 1374 related: force to load exactly the language requested and not any
fallback language. If the language file is missing, we tell it explicitely.
(0003317)
svn (reporter)
2010.01.10 00:26

[Subversion] r4644 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
feature 1374 related: improve the problems on translations. Ability to detect
if the key was duplicated from the reference language BUT not really
translated yet.
(0003318)
svn (reporter)
2010.01.10 00:52

[Subversion] r4646 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
feature 1374 related: don't display the validated keys as "untranslated yet".
(0003353)
plg (manager)
2010.01.26 10:41

Because we are not perfectly OK on the translation workflow between branch 2.0 and trunk, I don't backport this tool on trunk. We will do it as soon as needed.

- Issue History
Date Modified Username Field Change
2010.01.09 20:33 plg New Issue
2010.01.09 20:33 plg Status new => assigned
2010.01.09 20:33 plg Assigned To => plg
2010.01.09 20:33 plg browser => any
2010.01.09 20:33 plg Web server => Apache 1.3.x
2010.01.09 20:35 svn Checkin
2010.01.09 20:35 svn Note Added: 0003314
2010.01.09 20:37 svn Checkin
2010.01.09 20:37 svn Note Added: 0003315
2010.01.09 21:54 svn Checkin
2010.01.09 21:54 svn Note Added: 0003316
2010.01.10 00:26 svn Checkin
2010.01.10 00:26 svn Note Added: 0003317
2010.01.10 00:52 svn Checkin
2010.01.10 00:52 svn Note Added: 0003318
2010.01.26 10:41 plg Note Added: 0003353
2010.01.26 10:41 plg Status assigned => closed
2010.01.26 10:41 plg Resolution open => fixed
2010.01.26 10:41 plg Fixed in Version => 2.0.8


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker