Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001396 [Piwigo] photos minor always 2010.01.23 23:26 2010.01.23 23:57
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.8 Product Version 2.0.0
  Target Version 2.0.8 Product Build
Summary 0001396: photo deletion doesn't remove category representative orphans
Description When you delete a photo, if it was used a category representative in a category the photo was not associate to, the representative remains the deleted photo. This produces a warning on gallery side when trying to display the category representative.

The current workaround is to perform an "Update categories informations" in Administration>Specials>Maintenance, but it should be done in delete_elements also.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0003343)
svn (reporter)
2010.01.23 23:56

[Subversion] r4730 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
bug 1396: when a photo was deleted, the code to avoid orphans as category
representative was 1) wrong (because a photo doesn't have to belong to a
category to represent it) 2) at the wrong place.
(0003344)
svn (reporter)
2010.01.23 23:57

[Subversion] r4731 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r4730 from branch 2.0 to trunk

bug 1396: when a photo was deleted, the code to avoid orphans as category
representative was 1) wrong (because a photo doesn't have to belong to a
category to represent it) 2) at the wrong place.

- Issue History
Date Modified Username Field Change
2010.01.23 23:26 plg New Issue
2010.01.23 23:26 plg Status new => assigned
2010.01.23 23:26 plg Assigned To => plg
2010.01.23 23:26 plg browser => any
2010.01.23 23:26 plg Web server => Apache 1.3.x
2010.01.23 23:56 svn Checkin
2010.01.23 23:56 svn Note Added: 0003343
2010.01.23 23:56 plg Description Updated
2010.01.23 23:57 svn Checkin
2010.01.23 23:57 svn Note Added: 0003344
2010.01.23 23:57 plg Status assigned => closed
2010.01.23 23:57 plg Resolution open => fixed
2010.01.23 23:57 plg Fixed in Version => 2.0.8


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker