Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001431 [Piwigo] web API major always 2010.02.13 00:01 2010.02.13 00:05
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.9 Product Version 2.0.8
  Target Version 2.0.9 Product Build
Summary 0001431: community users can't see empty categories
Description When using the Community plugin, a non admin user can use pLoader to see the list of categories and upload.

With 0001053, we hide categories that contain no photo. Only pure administrators don't follow this rule. Unfortunately, community users (allowed to upload) are not pure administrators. So in pLoader they can't see the empty categories (even the ones they create by themselves...)
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0003390)
plg (manager)
2010.02.13 00:02

I've submitted the bug in Piwigo project and not in Community plugin, because I already coded the change and I know there is no change to apply in Community.
(0003391)
svn (reporter)
2010.02.13 00:04

[Subversion] r4883 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
bug 1431: Community users now can see empty categories just like any admin.
(0003392)
svn (reporter)
2010.02.13 00:05

[Subversion] r4884 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r4883 from branch 2.0 to trunk

bug 1431: Community users now can see empty categories just like any admin.

- Issue History
Date Modified Username Field Change
2010.02.13 00:01 plg New Issue
2010.02.13 00:01 plg Status new => assigned
2010.02.13 00:01 plg Assigned To => plg
2010.02.13 00:01 plg browser => any
2010.02.13 00:01 plg Web server => Apache 1.3.x
2010.02.13 00:02 plg Note Added: 0003390
2010.02.13 00:04 svn Checkin
2010.02.13 00:04 svn Note Added: 0003391
2010.02.13 00:05 svn Checkin
2010.02.13 00:05 svn Note Added: 0003392
2010.02.13 00:05 plg Status assigned => closed
2010.02.13 00:05 plg Resolution open => fixed
2010.02.13 00:05 plg Fixed in Version => 2.0.9


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker