Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001491 [Piwigo] template feature N/A 2010.03.09 10:46 2010.04.14 17:12
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.0RC1 Product Version
  Target Version 2.1.0RC1 Product Build
Summary 0001491: administration panel header
Description Add an header in the administration panel.

* the panel is not theme dependant
* the panel reminds the gallery title
* the panel includes "Administration Panel" (clickable, to return to admin homepage)
* the panel includes a "visit gallery" link
* the panel includes a "logout" link
* the panel includes a "Hello, <username>"
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0003512)
svn (reporter)
2010.03.10 00:19

[Subversion] r5098 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 1491: administration panel header/footer. Graphicaly outside the
administration theme. The header includes the gallery title with a link to
gallery, a theme changer, an explicit "visit gallery" link, a logout link.
The footer includes links to piwigo.org (homepage, documentation, forum) and
the contact webmaster link.

Due to new header/footer, I've removed the "Links" section in the menubar.

The new footer sticks to the bottom of the browser window.

I've slightly "rounded" grum tabs to look like the menubar borders.

Graphical illustration (top left and bottom left leaves) were removed to
improve readability. They make things beautiful on gallery side, they
decrease usability on admin side.

Piwigo logo was removed to save space on administration footer. It would be
nice to have a small logo to place bottom left in the footer next to
"Powered by Piwigo".

Links>Administration link was replaced by a big link box just above the
menubar.

The H2 was outside the #content box, nearly invisible on top right corner.
Now it is 1) easy to read 2) inside #content.

feature 1490: ability to switch from goto/roma to goto/clear with a single
click in administration header.

The global organisation of the page is quite heavily changed. The global
layout is:

body#theAdminPage
body#theAdminPage > #the_page
body#theAdminPage > #the_page > #pwgHead
body#theAdminPage > #the_page > #pwgMain
body#theAdminPage > #the_page > #pwgMain > #menubar
body#theAdminPage > #the_page > #pwgMain > #content
body#theAdminPage > #the_page > #footer

- Issue History
Date Modified Username Field Change
2010.03.09 10:46 plg New Issue
2010.03.09 10:46 plg Status new => assigned
2010.03.09 10:46 plg Assigned To => plg
2010.03.09 10:46 plg browser => any
2010.03.09 10:46 plg Web server => Apache 1.3.x
2010.03.10 00:19 svn Checkin
2010.03.10 00:19 svn Note Added: 0003512
2010.04.14 17:12 plg Status assigned => closed
2010.04.14 17:12 plg Resolution open => fixed
2010.04.14 17:12 plg Fixed in Version => 2.1.0RC1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker