Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001501 [Piwigo] authentication minor always 2010.03.12 10:56 2010.05.05 00:22
Reporter stefan View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.0 Product Version 2.0.9
  Target Version 2.1.0 Product Build
Summary 0001501: apache_authentication=true doesn't work when $_SERVER['REMOTE_USER'] is not set
Description In some cases (depending on configuration of apache and php) the server sets the attribute REDIRECT_REMOTE_USER instead of REMOTE_USER, when using basic authentication.

In this case the functions in include/user.inc.php will fail to determine the user id of the user who had logged in using basic authentication. And he need to login again using the form based login against the database.

I changed the source code to use REDIRECT_REMOTE_USER and it works for me.

I think it would be a nice solution if you can use the REDIRECT_REMOTE_USER attribute as fallback when REMOTE_USER is not set.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version 5.0
PHP version 5.3.2
Web server unknown
Attached Files

- Relationships

-  Notes
(0003836)
svn (reporter)
2010.05.05 00:21

[Subversion] r6074 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
bug 1501 fixed: with apache_authentication, fall back to REDIRECT_REMOTE_USER
if REMOTE_USER is not set.

- Issue History
Date Modified Username Field Change
2010.03.12 10:56 stefan New Issue
2010.03.12 10:56 stefan browser => any
2010.03.12 10:56 stefan MySQL version => 5.0
2010.03.12 10:56 stefan PHP version => 5.3.2
2010.03.12 10:56 stefan Web server => unknown
2010.03.15 12:56 plg Target Version => 2.0.10
2010.04.08 21:32 plg Assigned To => plg
2010.04.08 21:32 plg Status new => assigned
2010.04.08 21:32 plg Target Version 2.0.10 => 2.1.0RC3
2010.04.27 01:09 plg Target Version 2.1.0RC3 => 2.1.0
2010.05.05 00:21 svn Checkin
2010.05.05 00:21 svn Note Added: 0003836
2010.05.05 00:22 plg Status assigned => closed
2010.05.05 00:22 plg Resolution open => fixed
2010.05.05 00:22 plg Fixed in Version => 2.1.0


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker