Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001507 [Piwigo] template feature have not tried 2010.03.15 14:26 2010.04.14 17:13
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.0RC1 Product Version
  Target Version 2.1.0RC1 Product Build
Summary 0001507: theme manager : install themes from piwigo.org
Description Here is the situation: you find themes on piwigo.org/ext. You need them in the "themes" directory of your Piwigo installation.

To make users life easier, let Piwigo find and install the themes you like.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0003534)
svn (reporter)
2010.03.15 14:35

[Subversion] r5143 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 1507: ability to install themes directly from piwigo.org/ext.

The theme manager backend for installation is the plugin manager backend,
because they are very close.

thanks to feature:1502, installing a theme and installing a plugin are very
similare operations. The only differences are the installation directory and
the main file to find in the archive.

This is only the very first step, the "add new theme" screen needs many
improvements, to begin with display style.
(0003536)
svn (reporter)
2010.03.15 21:50

[Subversion] r5145 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 1507: better display for available themes (floating boxes)
(0003538)
svn (reporter)
2010.03.17 01:48

[Subversion] r5153 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 1514: new screen to manage installed themes; activate, deactivate,
delete, set as default.

plugins.class.php was merged back to a state it doesn't manage themes at all.
themes.class.php was created instead, from a duplication of plugins.class.php
and strongly modified then.

feature 1507: the display of available themes is now much more "graphic".
(0003556)
svn (reporter)
2010.03.19 10:52

[Subversion] r5186 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 1514, feature 1507: improvement, the themeBoxes height adjusts
automatically depending on the content.

- Issue History
Date Modified Username Field Change
2010.03.15 14:26 plg New Issue
2010.03.15 14:26 plg Status new => assigned
2010.03.15 14:26 plg Assigned To => plg
2010.03.15 14:26 plg browser => any
2010.03.15 14:26 plg Web server => Apache 1.3.x
2010.03.15 14:35 svn Checkin
2010.03.15 14:35 svn Note Added: 0003534
2010.03.15 21:50 svn Checkin
2010.03.15 21:50 svn Note Added: 0003536
2010.03.17 01:48 svn Checkin
2010.03.17 01:48 svn Note Added: 0003538
2010.03.19 10:52 svn Checkin
2010.03.19 10:52 svn Note Added: 0003556
2010.04.14 17:13 plg Status assigned => closed
2010.04.14 17:13 plg Resolution open => fixed
2010.04.14 17:13 plg Fixed in Version => 2.1.0RC1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker