Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001583 [Piwigo] tags feature N/A 2010.04.08 10:22 2010.04.10 11:48
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.0RC2 Product Version
  Target Version 2.1.0RC2 Product Build
Summary 0001583: simplify "related tags" ergonomy
Description 1) in the "related tags" block, replace the add_tag.png by a simple "+" character. It will keep the same size and color and is as much efficient.

2) for each tag, replace the 2 links (1 link on the "+", another link on the tag name) by a single link to create tag sets

3) display the remove_s.png in the page title as soon as the first tag (don't wait for the third tag)
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0003709)
svn (reporter)
2010.04.08 10:26

[Subversion] r5703 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 1583: replace add_tag.png icon by a simple "+" character in the
"related tags" block. Only keep one link for each tag in the "related tags"
block.
(0003711)
svn (reporter)
2010.04.08 10:49

[Subversion] r5706 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 1583: (tag navigation ergonomy) in the page title, always display the
"remove tag" icon, whatever the number of tags.
(0003713)
rvelices (developer)
2010.04.08 13:59

Hello,
Concerning point 2) - is this something you really absolutely want to have ?
I prefer from far the current behaviour (also on my site you have a related tags section without the + sign when browsing a non tag section with images ...)
(0003714)
plg (manager)
2010.04.08 14:25

rvelices wrote:

> I prefer from far the current behaviour (also on my site you
> have a related tags section without the + sign when browsing
> a non tag section with images ...)

I was going to write you an email to understand why we had a if(!empty($U_ADD)) in the template. Now I understand.

I really think the new behavior is much simpler for users.

But your (specific?) feature is very interesting. How many tags you can display in this box when you're not browsing a tag? I think we should integrate it in core :-) it's a nice way to discover tag browsing, really good.

If I take your feature into account, then my opinion is the following: it's better to keep a single link for each tag. If you're already displaying a tag, then it "adds the tag", else it "display the tag".

On your website, if I'm looking at http://www.modusoptimus.com/pwg/index/tags/architecture [^] I see "+Japan" in the "related tags" menubar box. If I want to display all photos related to "Japan" and not "architecture+Japan", then I need 2 clicks: 1) click on "+Japan" in the "related tags" 2) you click on the "Japan" tag in the page title.

This is the way it works on Delicious.com and it's really much easier to display a set of tags. I'm 94.3% sure that only a few people understand that clicking on the "+" produces a different result than clicking on "Japan". That's a pity because this is the only way to display a set of tags and that this is feature Piwigo has and not many other web application has.
(0003715)
plg (manager)
2010.04.08 14:26

> If I take your feature into account, then my opinion is the
> following: it's better to keep a single link for each tag. If
> you're already displaying a tag, then it "adds the tag", else
> it "display the tag".

Of course, if we're not displaying a tag, then we don't have the "+" in front of the tag.
(0003717)
rvelices (developer)
2010.04.08 19:26

In related tags when not browsing a tag I display
 - maximum 8 tags
 - the tags for the currently displayed elements (not the entire page[items] - the difference comes if you have a navigation bar). Otherwise performance issues if we browse for example a huge category displayed in flat mode.

Let's go for the following:
- integration of my specific feature into piwigo core
- in php we generate both urls U_ADD and URL
- in the default template we keep the behaviour you propose ( if U_ADD defined then 1 link with + else 1 link URL)
- I can rewrite my template and do whatever I want with U_ADD and URL

Agree ?
(0003718)
plg (manager)
2010.04.08 20:37

Perfect.

In your specific feature, if there is no related tag, do you instantiate the menubar block?
(0003723)
rvelices (developer)
2010.04.08 22:01

> In your specific feature, if there is no related tag, do you instantiate the menubar block?
Not sure but I will make sure I won't instantiate it if there is no related tag

- Issue History
Date Modified Username Field Change
2010.04.08 10:22 plg New Issue
2010.04.08 10:22 plg Status new => assigned
2010.04.08 10:22 plg Assigned To => plg
2010.04.08 10:22 plg browser => any
2010.04.08 10:22 plg Web server => Apache 1.3.x
2010.04.08 10:26 svn Checkin
2010.04.08 10:26 svn Note Added: 0003709
2010.04.08 10:49 svn Checkin
2010.04.08 10:49 svn Note Added: 0003711
2010.04.08 10:49 plg Status assigned => closed
2010.04.08 10:49 plg Resolution open => fixed
2010.04.08 10:49 plg Fixed in Version => 2.1.0RC2
2010.04.08 13:59 rvelices Note Added: 0003713
2010.04.08 13:59 rvelices Status closed => feedback
2010.04.08 13:59 rvelices Resolution fixed => reopened
2010.04.08 14:25 plg Note Added: 0003714
2010.04.08 14:26 plg Note Added: 0003715
2010.04.08 19:26 rvelices Note Added: 0003717
2010.04.08 20:37 plg Note Added: 0003718
2010.04.08 22:01 rvelices Note Added: 0003723
2010.04.10 11:48 rvelices Status feedback => closed
2010.04.10 11:48 rvelices Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker