Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001639 [Piwigo] upload major always 2010.05.03 14:45 2010.05.03 14:49
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.0 Product Version 2.1.0RC3
  Target Version 2.1.0 Product Build
Summary 0001639: the upload form is not compatible uses the hard coded upload directory
Description while $conf['upload_dir'] exists and is used by web API
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0003828)
svn (reporter)
2010.05.03 14:49

[Subversion] r6052 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
bug 1639 fixed: the upload form now correctly uses the $conf['upload_dir']
parameter (web API already use it).

By default, the $conf['upload_dir'] is no longer dependent to PHPWG_ROOT_PATH
because it becomes a real mess when admin/include/uploadify.php (called
directly, not from an include) tries to perform an upload.

Improvement: make clearer how $conf['upload_dir'] can be set (relative to the
Piwigo installation directory + HTTP reachable)

- Issue History
Date Modified Username Field Change
2010.05.03 14:45 plg New Issue
2010.05.03 14:45 plg Status new => assigned
2010.05.03 14:45 plg Assigned To => plg
2010.05.03 14:45 plg browser => any
2010.05.03 14:45 plg Web server => Apache 1.3.x
2010.05.03 14:49 svn Checkin
2010.05.03 14:49 svn Note Added: 0003828
2010.05.03 14:49 plg Status assigned => closed
2010.05.03 14:49 plg Resolution open => fixed
2010.05.03 14:49 plg Fixed in Version => 2.1.0


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker