Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001683 [Piwigo] users & groups block always 2010.05.24 00:54 2011.02.03 12:28
Reporter plg View Status public  
Assigned To plg
Priority urgent Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.1 Product Version 2.1.0
  Target Version 2.1.1 Product Build
Summary 0001683: modify guest settings breaks registration
Description As explained by Leo in http://piwigo.org/forum/viewtopic.php?pid=113540#p113540 [^] if an administrator modifies guest settings, then registration is broken.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
related to 0001684closedplg migration task to check default theme/language 

-  Notes
(0003896)
svn (reporter)
2010.05.24 01:19

[Subversion] r6311 by plg on branch 2.1

-----[Subversion commit log]----------------------------------------------------
bug 1683 fixed: as soon as an admin modifies the admin>conf>options>guest settings, registration is broken. This is because user_infos.theme/language are emptied (while they should not).

I have also added an "automatic repair" piece of code in get_default_user_info function. This piece of code should be removed for 2.2 with the appropriate migration task.
(0003901)
svn (reporter)
2010.05.24 01:42

[Subversion] r6314 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r6311 from branch 2.1 to trunk

bug 1683 fixed: as soon as an admin modifies the admin>conf>options>guest settings, registration is broken. This is because user_infos.theme/language are emptied (while they should not).

I have also added an "automatic repair" piece of code in get_default_user_info function. This piece of code should be removed for 2.2 with the appropriate migration task.
(0004781)
svn (reporter)
2011.02.03 12:28

[Subversion] r9074 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
bug 1684 fixed: the fix for bug:1683 was an "automatic repair" but it adds
useless code. We couldn't create a migration task on the stable branch, but
on trunk this is possible.

- Issue History
Date Modified Username Field Change
2010.05.24 00:54 plg New Issue
2010.05.24 00:54 plg Status new => assigned
2010.05.24 00:54 plg Assigned To => plg
2010.05.24 00:54 plg browser => any
2010.05.24 00:54 plg Web server => Apache 1.3.x
2010.05.24 01:19 svn Checkin
2010.05.24 01:19 svn Note Added: 0003896
2010.05.24 01:23 plg Relationship added related to 0001684
2010.05.24 01:23 plg Status assigned => closed
2010.05.24 01:23 plg Resolution open => fixed
2010.05.24 01:23 plg Fixed in Version => 2.1.1
2010.05.24 01:42 svn Checkin
2010.05.24 01:42 svn Note Added: 0003901
2011.02.03 12:28 svn Checkin
2011.02.03 12:28 svn Note Added: 0004781


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker