Piwigo Bugtracker

Piwigo bug tracker has moved to Github

This bugtracker is kept to provide history on old issues.


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001851Piwigonotificationpublic2010.09.13 11:562011.09.08 12:56
Reporterrvelices 
Assigned Torvelices 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
PlatformOSOS Version
Product Version2.1.2 
Target VersionFixed in Version2.1.3 
Summary0001851: duplicate images in RSS feed (or notification by email)
Descriptionbecause of missing DISTINCT in notification sql queries, the RSS feed might return the same image more than once resulting in double thumbnails (or even more thumbnails that were added at that date)
TagsNo tags attached.
browserany
Database engine and version
PHP version
Web serverApache 1.3.x
Attached Files

- Relationships

-  Notes
(0004157)
rvelices (developer)
2010.09.13 11:56
edited on: 2010.09.13 11:56

[Subversion] r6870
[Subversion] r6871

(0004186)
nikrou (developer)
2010.09.15 21:46

Adding distinct breaks sql queries with PostgreSQL database engine
(0004192)
rvelices (developer)
2010.09.16 10:02

I thought of it because you just removed DISTINCT when added Postgres compatibility (which resulted in this bug)
Would you mind making the correction yourself and especially could you document somewhere what are the rules when using DISTINCT with Postgres (I dont have Postgres and whatever the Postgres requirement, it seems very strange to me) ?
(0005493)
plg (manager)
2011.09.08 12:56

Issue closed unresolved, see 0002431 : Piwigo drops support for PostgreSQL/SQLite

- Issue History
Date Modified Username Field Change
2010.09.13 11:56 rvelices New Issue
2010.09.13 11:56 rvelices Status new => assigned
2010.09.13 11:56 rvelices Assigned To => rvelices
2010.09.13 11:56 rvelices browser => any
2010.09.13 11:56 rvelices Web server => Apache 1.3.x
2010.09.13 11:56 rvelices Note Added: 0004157
2010.09.13 11:56 rvelices Note Edited: 0004157
2010.09.13 11:57 rvelices Resolution open => fixed
2010.09.13 11:57 rvelices Fixed in Version => 2.1.3
2010.09.13 11:57 rvelices Status assigned => closed
2010.09.15 21:46 nikrou Note Added: 0004186
2010.09.15 21:46 nikrou Status closed => feedback
2010.09.15 21:46 nikrou Resolution fixed => reopened
2010.09.16 10:02 rvelices Note Added: 0004192
2011.09.08 12:56 plg Note Added: 0005493
2011.09.08 12:56 plg Status feedback => closed


Copyright © 2000 - 2018 MantisBT Team
Contact
Powered by Mantis Bugtracker