Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002003 [Piwigo] web API minor random 2010.11.03 23:19 2010.11.03 23:26
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.5 Product Version 2.1.4
  Target Version 2.1.5 Product Build
Summary 0002003: [pwg.images.setInfo] randomly fails on calling invalidate_user_cache
Description The Lightroom publish to Piwigo plugin developer has reported that sometimes he received :

Fatal error: Call to undefined function invalidate_user_cache() in .../include/ws_functions.inc.php on line 1917

when calling pwg.images.setInfo with parameters:

* image_id = 111
* categories= 34;35
Steps To Reproduce I can't reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0004460)
svn (reporter)
2010.11.03 23:23

[Subversion] r7612 by plg on branch 2.1

-----[Subversion commit log]----------------------------------------------------
bug 2003 fixed: random failure on calling invalidate_user_cache. I move the
include of admin functions outside conditional blocks, even if we should also
enter the first block.
(0004461)
svn (reporter)
2010.11.03 23:24

[Subversion] r7613 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r7612 from branch 2.1 to trunk

bug 2003 fixed: random failure on calling invalidate_user_cache. I move the
include of admin functions outside conditional blocks, even if we should also
enter the first block.


- Issue History
Date Modified Username Field Change
2010.11.03 23:19 plg New Issue
2010.11.03 23:19 plg Status new => assigned
2010.11.03 23:19 plg Assigned To => plg
2010.11.03 23:19 plg browser => any
2010.11.03 23:19 plg Web server => Apache 1.3.x
2010.11.03 23:23 svn Checkin
2010.11.03 23:23 svn Note Added: 0004460
2010.11.03 23:24 svn Checkin
2010.11.03 23:24 svn Note Added: 0004461
2010.11.03 23:26 plg Status assigned => closed
2010.11.03 23:26 plg Resolution open => fixed
2010.11.03 23:26 plg Fixed in Version => 2.1.5


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker