Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002035 [Piwigo] web API minor always 2010.11.15 10:26 2010.11.15 10:49
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.6 Product Version 2.1.5
  Target Version 2.1.6 Product Build
Summary 0002035: [pwg.images.addComment] a warning breaks page parsing when meeting flooding limits
Description If you call pwg.images.addComment twice without waiting for $conf['anti-flood_time'] seconds (60 seconds by default), then you get a

> Warning: Header may not contain more than a single header, new line detected...

in the returned content. And it breaks JSON parsing.
Steps To Reproduce
Additional Information This is because pwg.images.addComment merges information message with a new line character and use this merged information as the error message in the HTTP response header. New line is a forbidden character in HTTP header.
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0004498)
svn (reporter)
2010.11.15 10:46

[Subversion] r7781 by plg on branch 2.1

-----[Subversion commit log]----------------------------------------------------
bug 2035 fixed: avoid sending multiple line error code in HTTP header. This
was breaking the JSON parsing on pwg.images.addComment response from Piwigo
because of an raw HTML warning.
(0004499)
svn (reporter)
2010.11.15 10:48

[Subversion] r7782 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r7781 from branch 2.1 to trunk

bug 2035 fixed: avoid sending multiple line error code in HTTP header. This
was breaking the JSON parsing on pwg.images.addComment response from Piwigo
because of an raw HTML warning.


- Issue History
Date Modified Username Field Change
2010.11.15 10:26 plg New Issue
2010.11.15 10:26 plg Status new => assigned
2010.11.15 10:26 plg Assigned To => plg
2010.11.15 10:26 plg browser => any
2010.11.15 10:26 plg Web server => Apache 1.3.x
2010.11.15 10:46 svn Checkin
2010.11.15 10:46 svn Note Added: 0004498
2010.11.15 10:48 svn Checkin
2010.11.15 10:48 svn Note Added: 0004499
2010.11.15 10:49 plg Status assigned => closed
2010.11.15 10:49 plg Resolution open => fixed
2010.11.15 10:49 plg Fixed in Version => 2.1.6


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker