Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002040 [Piwigo] upload feature N/A 2010.11.24 11:23 2011.02.05 21:10
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.2.0RC1 Product Version 2.1.5
  Target Version 2.2.0RC1 Product Build
Summary 0002040: automatic rotation of the photo based on EXIF Orientation
Description When the EXIF Orientation tag says "please rotate me before display", then Piwigo should rotate the photo at upload time.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
has duplicate 0001398closed EXIF orientation display 

-  Notes
(0004511)
svn (reporter)
2010.11.24 13:45

[Subversion] r7868 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2040 added: automatic rotation of the photo based on EXIF Orientation.

The code could have been shorter but this one 1) checks the resize dimension
with the rotation in mind 2) rotates the photo once resized to reduce memory
used.
(0004512)
plg (manager)
2010.11.24 13:46

We should also add a "automatic rotation" option on screen [Administration > Photos > Add > Settings] (checked by default)
(0004513)
Gotcha (developer)
2010.11.24 23:54

Truth
(0004669)
svn (reporter)
2011.01.19 15:00

[Subversion] r8763 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2040: to finish the "automatic rotation" feature, I had configuration
setting. I choose to have it in the configuration file and not in the web
interface because it is a bit too technical and useful only in very specific
cases (when buggy software performed a rotation before without updating the
EXIF "orientation" tag)
(0004787)
svn (reporter)
2011.02.05 21:10

[Subversion] r9090 by Eric on extension NBC_UserAdvManager

-----[Subversion commit log]----------------------------------------------------
bug 2040 fixed : Small english translation improved
Set installation compatibility to MySql 5.5 and above

- Issue History
Date Modified Username Field Change
2010.11.24 11:23 plg New Issue
2010.11.24 11:23 plg Status new => assigned
2010.11.24 11:23 plg Assigned To => plg
2010.11.24 11:23 plg browser => any
2010.11.24 11:23 plg Web server => Apache 1.3.x
2010.11.24 13:45 svn Checkin
2010.11.24 13:45 svn Note Added: 0004511
2010.11.24 13:46 plg Note Added: 0004512
2010.11.24 23:54 Gotcha Note Added: 0004513
2010.11.24 23:58 Gotcha Relationship added has duplicate 0001398
2011.01.19 15:00 svn Checkin
2011.01.19 15:00 svn Note Added: 0004669
2011.01.19 15:01 plg Status assigned => closed
2011.01.19 15:01 plg Resolution open => fixed
2011.01.19 15:01 plg Fixed in Version => 2.2.0RC1
2011.02.05 21:10 svn Checkin
2011.02.05 21:10 svn Note Added: 0004787


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker