Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000205 [Piwigo] installation & upgrade minor have not tried 2005.11.14 06:41 2005.12.03 23:26
Reporter xaviounet View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6 branch Product Version 1.5.0
  Target Version Product Build
Summary 0000205: categories not represented after upgrade from 1.4.1 to 1.5.0
Description Hi. I just upgraded from 1.4.1 (with some modifications like mod news, some of the features from pse mod and some personal modifications) to 1.5.0. After this upgrade, some categories were not displayed (had no representative image, so they could be reached only from the menu). At first I began to set representatives myself so that they appear again, but a simple synchronisation and they appeared again. It seems that only categories with sub-categories were affected. Not really important, but it might be confusing at first when you upgrade.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser IE
Database engine and version
PHP version free.fr
Web server free.fr
Attached Files

- Relationships

-  Notes
(0000433)
plg (manager)
2005.11.16 22:57

This kind of situation make me feel confident that new screen [Administration>General>Maintenance] would be useful :-) Action "update categories informations" is your friend.

Since you had a modded PhpWebGallery, particulary about representative pictures, do you think a code modification would make sense ? (I'm talking about automatically update categories informations at the end of upgrade).
(0000434)
xaviounet (reporter)
2005.11.17 00:43

Well changing the code doesn't make sense.
But to make it simple, at the end of the update, there is a screen saying that you have to delete install files and I don't know what else. An instruction may be added there saying that you have to perform maintenance after the update if everything is not there. It might seem obvious to do it and it was not a real problem for me, but for some people, they might think they lost their pictures.
Just a suggestion anyway, it's not a main issue ;-)
(0000487)
plg (manager)
2005.12.03 23:26

Corrected only in BSF (for branch 1.6) [Subversion] r971

- Issue History
Date Modified Username Field Change
2005.11.14 06:41 xaviounet New Issue
2005.11.14 06:41 xaviounet browser => IE
2005.11.14 06:41 xaviounet PHP version => free.fr
2005.11.14 06:41 xaviounet Web server => free.fr
2005.11.16 22:57 plg Note Added: 0000433
2005.11.16 22:57 plg Assigned To => plg
2005.11.16 22:57 plg Status new => feedback
2005.11.17 00:43 xaviounet Note Added: 0000434
2005.11.18 23:12 plg Status feedback => assigned
2005.12.03 23:26 plg Note Added: 0000487
2005.12.03 23:26 plg Status assigned => closed
2005.12.03 23:26 plg Resolution open => fixed
2005.12.03 23:26 plg Fixed in Version => 1.6 branch


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker