Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002104 [Piwigo] metadata minor have not tried 2011.01.12 15:57 2011.01.12 15:59
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.6 Product Version 2.1.5
  Target Version 2.1.6 Product Build
Summary 0002104: error message when displaying metadata if HD access is denied
Description If a user has no right to see the high definition version of the photo
+ if only the HD version contains EXIF/IPTC metadata
+ if the user asks to display metadata on picture.php

then you get an error message because Piwigo reads $picture['current']['high_url'] while it was not set due to permissions.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0004641)
svn (reporter)
2011.01.12 15:58

[Subversion] r8630 by plg on branch 2.1

-----[Subversion commit log]----------------------------------------------------
bug 2104 fixed: ability to display EXIF/IPTC metadata from HD even if the HD
is not visible for user
(0004642)
svn (reporter)
2011.01.12 15:59

[Subversion] r8631 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r8630 from branch 2.1 to trunk

bug 2104 fixed: ability to display EXIF/IPTC metadata from HD even if the HD
is not visible for user


- Issue History
Date Modified Username Field Change
2011.01.12 15:57 plg New Issue
2011.01.12 15:57 plg Status new => assigned
2011.01.12 15:57 plg Assigned To => plg
2011.01.12 15:57 plg browser => any
2011.01.12 15:57 plg Web server => Apache 1.3.x
2011.01.12 15:58 svn Checkin
2011.01.12 15:58 svn Note Added: 0004641
2011.01.12 15:59 svn Checkin
2011.01.12 15:59 svn Note Added: 0004642
2011.01.12 15:59 plg Status assigned => closed
2011.01.12 15:59 plg Resolution open => fixed
2011.01.12 15:59 plg Fixed in Version => 2.1.6


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker