Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002152 [Piwigo] user comments feature always 2011.01.29 12:56 2011.04.16 20:06
Reporter eric View Status public  
Assigned To mistic100
Priority normal Resolution fixed Platform WampServer
Status closed   OS Windows Vista
Projection none   OS Version 2.1
ETA none Fixed in Version 2.2.1 Product Version 2.1.6
  Target Version 2.2.1 Product Build
Summary 0002152: Comments revalidation when modified
Description If gallery is set for the admin validates comments filed before publication and allows users to edit their own comments, users can modify the comments as they want (that's normal) but the admin no longer has to validate them again and they are immediately visible.

To enforce protection against Spam, admins should revalidate every change on comments in this case.
Steps To Reproduce
Additional Information http://fr.piwigo.org/forum/viewtopic.php?id=19385 [^]
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0004951)
svn (reporter)
2011.04.06 10:55

[Subversion] r10097 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
bug:2152 Comments revalidation when modified
(0004952)
rvelices (developer)
2011.04.06 11:20

Quick question: is there a reason to have changed picture_comment.inc.php in your commit ?

The test if (!isset($comment_action)) is completeley useless in my opinion ..
(0004953)
mistic100 (developer)
2011.04.06 11:31

it is, because for display a message I can't redirect the user, then $_POST['content'] is defined, and the page 'picture_comment.inc.php' try to add a new comment with the content of the updated comment.

But... it could be easier to unset $_POST['content'] after saving the comment.
will change this
(0004960)
svn (reporter)
2011.04.06 21:24

[Subversion] r10122 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
bug:2152 no special parameter for updated comment validation

- Issue History
Date Modified Username Field Change
2011.01.29 12:56 eric New Issue
2011.01.29 12:56 eric browser => any
2011.01.29 12:56 eric Web server => Apache 1.3.x
2011.04.02 15:39 mistic100 Issue Monitored: mistic100
2011.04.04 21:00 mistic100 Status new => assigned
2011.04.04 21:00 mistic100 Assigned To => mistic100
2011.04.06 10:55 svn Checkin
2011.04.06 10:55 svn Note Added: 0004951
2011.04.06 10:58 mistic100 Status assigned => resolved
2011.04.06 10:58 mistic100 Fixed in Version => 2.3
2011.04.06 10:58 mistic100 Resolution open => fixed
2011.04.06 11:20 rvelices Note Added: 0004952
2011.04.06 11:20 rvelices Status resolved => feedback
2011.04.06 11:20 rvelices Resolution fixed => reopened
2011.04.06 11:31 mistic100 Note Added: 0004953
2011.04.06 21:24 svn Checkin
2011.04.06 21:24 svn Note Added: 0004960
2011.04.06 21:31 mistic100 Status feedback => resolved
2011.04.06 21:31 mistic100 Fixed in Version 2.3 => 2.2.0
2011.04.06 21:31 mistic100 Resolution reopened => fixed
2011.04.09 18:06 mistic100 Issue End Monitor: mistic100
2011.04.16 20:05 plg Status resolved => closed
2011.04.16 20:06 plg Fixed in Version 2.2.0 => 2.2.1
2011.04.16 20:06 plg Target Version => 2.2.1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker