Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002268 [Piwigo] template major have not tried 2011.04.18 17:29 2011.04.19 22:10
Reporter flop25 View Status public  
Assigned To rvelices
Priority high Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.2.2 Product Version 2.2.1
  Target Version 2.2.2 Product Build
Summary 0002268: Required script loaded in the footer instead of the header
Description If it's required in the header and the footer, the script will be loaded in the footer instead of the header.
Steps To Reproduce {combine_script id='jquery.tipTip.minified' load='header' require='jquery' path='themes/OS_glass/tiptip/jquery.tipTip.minified.js'}
{footer_script require='jquery'}{literal}
$(document).ready(function () {
....{literal}{/footer_script}

will add the script jquery in the footer and not in the header !
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0005022)
rvelices (developer)
2011.04.19 09:10

I cannot reproduce. It should work correctly unless the header has already been parsed at the time of your call combine_script ...
(0005023)
flop25 (developer)
2011.04.19 13:36

But the script (tipTip here) is loaded in the header but not the jquery required !
The {combine} tag is from a theme (OS_glass as you can see) and the footer tag is from a Template ext (mainpage_categories)
(0005024)
svn (reporter)
2011.04.19 22:08

[Subversion] r10503 by rvelices on trunk

-----[Subversion commit log]----------------------------------------------------
bug:2268 combine_script - sometimes precedent scripts were not being loaded before ...
in admin, the accordion is loaded in the header (admin pages have the same header combined script, but usually different bottom scripts)
(0005025)
svn (reporter)
2011.04.19 22:09

[Subversion] r10504 by rvelices on branch 2.2

-----[Subversion commit log]----------------------------------------------------
bug:2268 combine_script - sometimes precedent scripts were not being loaded before ...
in admin, the accordion is loaded in the header (admin pages have the same header combined script, but usually different bottom scripts)

- Issue History
Date Modified Username Field Change
2011.04.18 17:29 flop25 New Issue
2011.04.18 17:29 flop25 browser => any
2011.04.18 17:29 flop25 Web server => Apache 1.3.x
2011.04.19 09:10 rvelices Note Added: 0005022
2011.04.19 13:36 flop25 Note Added: 0005023
2011.04.19 13:36 flop25 Issue Monitored: flop25
2011.04.19 14:54 flop25 Target Version => 2.2.2
2011.04.19 22:08 svn Checkin
2011.04.19 22:08 svn Note Added: 0005024
2011.04.19 22:09 svn Checkin
2011.04.19 22:09 svn Note Added: 0005025
2011.04.19 22:09 rvelices Status new => assigned
2011.04.19 22:09 rvelices Assigned To => rvelices
2011.04.19 22:10 rvelices Status assigned => closed
2011.04.19 22:10 rvelices Resolution open => fixed
2011.04.19 22:10 rvelices Fixed in Version => 2.2.2


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker