Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000228 [Piwigo] configuration tweak always 2005.12.01 22:02 2006.04.27 22:56
Reporter VDigital View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection tweak   OS Version
ETA none Fixed in Version 1.6.0RC2 Product Version 1.5.0
  Target Version Product Build
Summary 0000228: $conf['newcat_default_visible'] = 'true'; are false
Description Il n'y a pas de bonnes raisons "false" ou 'false' ou 'true" ou "true", c'est du texte bien entendu.

Ce n'est pas une connerie/étourderie car ce n'est pas vital.
Il y a un moment que je l'avais relevé...

Bon courrage pour la correction, t'as quelques modules à revoir.
Ça peut attendre la 1.6 à mon avis.
Même c'est du rapide quand même. ;-)
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0000485)
plg (manager)
2005.12.03 22:09

Correction prévue pour la branche 1.6.
(0000490)
VDigital (reporter)
2005.12.04 07:44

Now, the problem is...

On est en train de conseiller fortement config_local !!!
(0000855)
VDigital (reporter)
2006.04.26 07:36

Nouveautés à corriger en 1.6.0RC1

$conf['newcat_default_commentable'] = 'false';
$conf['newcat_default_uploadable'] = 'false';
$conf['newcat_default_visible'] = 'false';
$conf['newuser_default_enabled_high'] = 'false';

Il est encore temps.
(0000861)
plg (manager)
2006.04.26 22:56
edited on: 2006.04.26 22:56

- corrected on branch 1.6 [Subversion] r1277
- reported don BSF [Subversion] r1278

(0000867)
rvelices (developer)
2006.04.27 01:29

si $conf['newuser_default_enabled_high'] == false on ne peut plus creer d'utilisateur ( [mysql error 1048] Column 'enabled_high' cannot be null ).

boolean_to_string($conf{'newcat_default_status'}) ne pose pas de probleme, mais le status est 'public' ou 'private' et non boolean
(0000880)
plg (manager)
2006.04.27 22:56

Merci pour les remarques rvelices :-) j'en ai profité pour faire un petit ménage dans install.php.

- corrected on branch 1.6 [Subversion] r1282 and [Subversion] r1283
- reported on trunk [Subversion] r1284

- Issue History
Date Modified Username Field Change
2005.12.01 22:02 VDigital New Issue
2005.12.01 22:02 VDigital browser => any
2005.12.01 22:02 VDigital Web server => Apache 1.3.x
2005.12.03 22:09 plg Note Added: 0000485
2005.12.03 22:09 plg Assigned To => plg
2005.12.03 22:09 plg Status new => confirmed
2005.12.03 22:09 plg Projection none => tweak
2005.12.04 07:44 VDigital Note Added: 0000490
2006.04.26 07:36 VDigital Note Added: 0000855
2006.04.26 22:56 plg Note Added: 0000861
2006.04.26 22:56 plg Status confirmed => closed
2006.04.26 22:56 plg Resolution open => fixed
2006.04.26 22:56 plg Fixed in Version => 1.6.0RC2
2006.04.26 22:56 plg Note Edited: 0000861
2006.04.27 01:29 rvelices Status closed => feedback
2006.04.27 01:29 rvelices Resolution fixed => reopened
2006.04.27 01:29 rvelices Note Added: 0000867
2006.04.27 22:56 plg Note Added: 0000880
2006.04.27 22:56 plg Status feedback => closed
2006.04.27 22:56 plg Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker