Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002342 [Piwigo] web API major always 2011.06.14 13:50 2011.06.14 14:03
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.2.4 Product Version 2.2.2
  Target Version 2.2.4 Product Build
Summary 0002342: [pwg.images.setInfo] default value for privacy level fails with MySQL 5.5
Description The default value is $leve = 0, but $level != '' then return false, which generate a "UPDATE images SET level = NULL..." which is an error with MySQL 5.5 because images.level can't be null.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0005230)
svn (reporter)
2011.06.14 14:02

[Subversion] r11363 by plg on branch 2.2

-----[Subversion commit log]----------------------------------------------------
bug 2342 fixed: with MySQL 5.5, "set level = NULL" fails because images.level
is a NOT NULL field. The same test is performed in the same function
(mass_updates) but for array bigger than 10 rows.
(0005231)
svn (reporter)
2011.06.14 14:03

[Subversion] r11364 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r11363 from branch 2.2 to trunk

bug 2342 fixed: with MySQL 5.5, "set level = NULL" fails because images.level
is a NOT NULL field. The same test is performed in the same function
(mass_updates) but for array bigger than 10 rows.


- Issue History
Date Modified Username Field Change
2011.06.14 13:50 plg New Issue
2011.06.14 13:50 plg Status new => assigned
2011.06.14 13:50 plg Assigned To => plg
2011.06.14 13:50 plg browser => any
2011.06.14 13:50 plg Web server => Apache 1.3.x
2011.06.14 14:02 svn Checkin
2011.06.14 14:02 svn Note Added: 0005230
2011.06.14 14:03 svn Checkin
2011.06.14 14:03 svn Note Added: 0005231
2011.06.14 14:03 plg Status assigned => closed
2011.06.14 14:03 plg Resolution open => fixed
2011.06.14 14:03 plg Fixed in Version => 2.2.4


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker