Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002373 [Piwigo] upload minor always 2011.07.05 09:27 2011.08.18 16:47
Reporter benoit View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.3.0RC1 Product Version 2.2.3
  Target Version 2.3.0RC1 Product Build
Summary 0002373: Multiple file upload blocked by an error on any single file
Description Using the multiple files upload, if an error occurs, the process doesn't end up correctly :
– no album is created (in cases it had to),
– the pictures are not associated with the album,
– the confidentiality level is set to "Admin",
– the end-of-upload page ("processed=1") never loads.

I am not sure it happens with every error, but at least it does with the "File too big" error.
Steps To Reproduce
Additional Information Forum topic (in french) : http://fr.piwigo.org/forum/viewtopic.php?pid=173168 [^]
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0005407)
svn (reporter)
2011.08.17 21:56

[Subversion] r11962 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2406 added: if the user wants a new album in the upload form, the album
is created before the start of the upload. The ergonomy is now simpler, the
page is smaller and cleaner.

bug 2373 fixed: now that album is created before upload, uploadify.php gets the
category_id and the level: as soon as it is uploaded (function add_uploaded_file)
the photo gets its final privacy level and is directly associated to the album.
This way, we can have an error on a photo without making orphan all photos of
the same upload group.

feature 2405 added: as soon as a photo is uploaded, its thumbnail is displayed
in the "Uploaded Photos" fieldset, without waiting for other photos to be
uploaded. The latest photos comes first.

I have slighlty changed the integration of colorbox in core. Now we have 2
styles available and by default, we use style2 (overlay in black, title and
control icons outside the popup). It is also used for zooming on bulk manager
in unit mode.

display change: on each uploading photos, instead of showing the transfer
speed, we display the transfer progression in %

bug fixed: the color of the "Start Upload" button was not correct because the
button was not a submit button but a simple type=button.

language: "Upload" button becomes "Start Upload" button.

- Issue History
Date Modified Username Field Change
2011.07.05 09:27 benoit New Issue
2011.07.05 09:27 benoit browser => any
2011.07.05 09:27 benoit Web server => Apache 1.3.x
2011.08.17 21:56 svn Checkin
2011.08.17 21:56 svn Note Added: 0005407
2011.08.18 16:47 plg Assigned To => plg
2011.08.18 16:47 plg Status new => closed
2011.08.18 16:47 plg Resolution open => fixed
2011.08.18 16:47 plg Fixed in Version => 2.3.0RC1
2011.08.18 16:47 plg Target Version => 2.3.0RC1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker