Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002440 [Piwigo] other major always 2011.09.16 22:50 2011.10.04 22:55
Reporter eric View Status public  
Assigned To rvelices
Priority normal Resolution fixed Platform Apache
Status closed   OS Linux
Projection none   OS Version PWG 2.2
ETA none Fixed in Version 2.3.0 Product Version 2.3.0RC2
  Target Version 2.3.0 Product Build
Summary 0002440: Fatal error when deleting a rate
Description If admin wants to delete a rate on a picture, a fatal error occurs : Fatal error: Call to undefined function update_rating_score() in /mnt/117/free.fr/8/d/mysite/piwigo230RC2/admin/rating.php on line 88
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0005534)
eric (developer)
2011.09.17 15:15

I've tryed to fix this by adding an inclusion of ../include/functions_rate.inc.php into ../admin/rate.php but another error occurs :

Warning: Division by zero in /mnt/117/free.fr/8/d/monsite/piwigo230RC2/include/functions_rate.inc.php on line 153
Warning: Division by zero in /mnt/117/free.fr/8/d/monsite/piwigo230RC2/include/functions_rate.inc.php on line 154

This is because I deleted the only one notation of a picture. Does a simple control of "$all_rates_count" value be good enough ?
(0005615)
svn (reporter)
2011.09.29 06:13

[Subversion] r12255 by rvelices on trunk

-----[Subversion commit log]----------------------------------------------------
bug 2440 : deleting a rate from admin was missing an include_once

- Issue History
Date Modified Username Field Change
2011.09.16 22:50 eric New Issue
2011.09.16 22:50 eric browser => any
2011.09.16 22:50 eric Web server => Apache 1.3.x
2011.09.17 14:35 eric Issue Monitored: eric
2011.09.17 15:15 eric Note Added: 0005534
2011.09.17 22:54 plg Assigned To => rvelices
2011.09.17 22:54 plg Status new => assigned
2011.09.29 06:13 svn Checkin
2011.09.29 06:13 svn Note Added: 0005615
2011.10.04 22:55 plg Status assigned => closed
2011.10.04 22:55 plg Resolution open => fixed
2011.10.04 22:55 plg Fixed in Version => 2.3.0
2011.10.04 22:55 plg Target Version => 2.3.0


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker