Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002449 [Piwigo] tags minor have not tried 2011.09.29 15:46 2011.09.30 10:12
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.3.0 Product Version 2.3.0RC2
  Target Version 2.3.0 Product Build
Summary 0002449: multilanguage tags trigger duplicate entry in database
Description if you have a tag [lang=default]landscape[/lang][lang=fr]paysage[/lang], if you add it to a photo, in its "tags" box, the photo will show the 2 tags "landscape" and "paysage". This generates an error at form validation : duplicate entry. This is because we try to insert twice the same tag to the same photo.

The tags box should only display the tag in the current user language (but we should keep the 2 tags in the auto-completion list)
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0005617)
svn (reporter)
2011.09.29 15:48

[Subversion] r12259 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
bug 2449 fixed: in the "tags box" on batch manager and picture_modify, we
should only display the tag in the current user language, not the tag in all
available languages.

- Issue History
Date Modified Username Field Change
2011.09.29 15:46 plg New Issue
2011.09.29 15:46 plg Status new => assigned
2011.09.29 15:46 plg Assigned To => plg
2011.09.29 15:46 plg browser => any
2011.09.29 15:46 plg Web server => Apache 1.3.x
2011.09.29 15:48 svn Checkin
2011.09.29 15:48 svn Note Added: 0005617
2011.09.30 10:12 plg Status assigned => closed
2011.09.30 10:12 plg Resolution open => fixed
2011.09.30 10:12 plg Fixed in Version => 2.3.0RC3


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker