Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002489 [Piwigo] web API feature have not tried 2011.10.31 11:23 2011.12.16 10:11
Reporter Gotcha View Status public  
Assigned To plg
Priority normal Resolution fixed Platform Microsoft
Status closed   OS Windows Seven
Projection none   OS Version x64
ETA none Fixed in Version 2.3.2 Product Version 2.3.0
  Target Version 2.3.2 Product Build
Summary 0002489: [pwg.images.setInfo] ability to update "original filename"
Description Today, there is nothing to be able to change the field "original name" pictures.
To re-publish the photos where the file name changes, it lacks a method.
Steps To Reproduce
Additional Information Contact Gotcha or Vladimir (alloyphoto).
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0005846)
svn (reporter)
2011.12.13 16:21

[Subversion] r12729 by plg on branch 2.3

-----[Subversion commit log]----------------------------------------------------
feature 2489 added: ability to update "file" info in pwg.images.setInfo
(0005847)
svn (reporter)
2011.12.13 16:21

[Subversion] r12730 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r12729 from branch 2.3 to trunk

feature 2489 added: ability to update "file" info in pwg.images.setInfo
(0005848)
rvelices (developer)
2011.12.14 07:38

If the photo is not uploaded; but synchronized through the file system it should not be allowed to change the file column because it is very important (category directory + filename -> path)
(0005849)
plg (manager)
2011.12.14 09:27

OK, you're right. I'll add a check for this specific info.
(0005851)
svn (reporter)
2011.12.16 10:10

[Subversion] r12738 by plg on branch 2.3

-----[Subversion commit log]----------------------------------------------------
feature 2489 updated: photos added by synchronization can't update their "file" field
(0005852)
svn (reporter)
2011.12.16 10:10

[Subversion] r12739 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r12738 from branch 2.3 to trunk

feature 2489 updated: photos added by synchronization can't update their "file" field


- Issue History
Date Modified Username Field Change
2011.10.31 11:23 Gotcha New Issue
2011.10.31 11:23 Gotcha Status new => assigned
2011.10.31 11:23 Gotcha Assigned To => plg
2011.10.31 11:23 Gotcha browser => any
2011.10.31 11:23 Gotcha Web server => Apache 1.3.x
2011.12.13 16:09 plg Summary To change the field "original name" => [pwg.images.setInfo] ability to update "original filename"
2011.12.13 16:21 svn Checkin
2011.12.13 16:21 svn Note Added: 0005846
2011.12.13 16:21 svn Checkin
2011.12.13 16:21 svn Note Added: 0005847
2011.12.13 16:21 plg Status assigned => closed
2011.12.13 16:21 plg Resolution open => fixed
2011.12.13 16:21 plg Fixed in Version => 2.3.2
2011.12.13 16:21 plg Target Version => 2.3.2
2011.12.14 07:38 rvelices Note Added: 0005848
2011.12.14 07:38 rvelices Status closed => feedback
2011.12.14 07:38 rvelices Resolution fixed => reopened
2011.12.14 09:27 plg Note Added: 0005849
2011.12.16 10:10 svn Checkin
2011.12.16 10:10 svn Note Added: 0005851
2011.12.16 10:10 svn Checkin
2011.12.16 10:10 svn Note Added: 0005852
2011.12.16 10:11 plg Status feedback => closed
2011.12.16 10:11 plg Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker