Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002529 [Piwigo] web API major sometimes 2011.12.05 09:57 2011.12.05 10:10
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.3.2 Product Version 2.3.1
  Target Version 2.3.2 Product Build
Summary 0002529: always_populate_raw_post_data "On" and "Unknown request format" on post requests
Description When you call ws.php in POST, if you have the Apache setting always_populate_raw_post_data set to "On", then ws.php sets the $requestFormat to "json" but ws_core can only handle the "rest" requestFormat.

See details in rvelices post http://piwigo.org/forum/viewtopic.php?pid=110379#p110379 [^]

alloyphoto gives a workaround with an .htaccess file on http://piwigo.org/forum/viewtopic.php?pid=126216#p126216 [^] but we'd better fix it in Piwigo core since we can only handle the "rest" requestFormat for now.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0005833)
svn (reporter)
2011.12.05 10:09

[Subversion] r12694 by plg on branch 2.3

-----[Subversion commit log]----------------------------------------------------
bug 2529 fixed: Piwigo API can only handle the "rest" requestFormat.
If we try to search for another request format the only result is an
"Unknown request format" error for the client. This error happens when
always_populate_raw_post_data is On (which is not the default Apache
setting).
(0005834)
svn (reporter)
2011.12.05 10:09

[Subversion] r12695 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r12694 from branch 2.3 to trunk

bug 2529 fixed: Piwigo API can only handle the "rest" requestFormat.
If we try to search for another request format the only result is an
"Unknown request format" error for the client. This error happens when
always_populate_raw_post_data is On (which is not the default Apache
setting).


- Issue History
Date Modified Username Field Change
2011.12.05 09:57 plg New Issue
2011.12.05 09:57 plg Status new => assigned
2011.12.05 09:57 plg Assigned To => plg
2011.12.05 09:57 plg browser => any
2011.12.05 09:57 plg Web server => Apache 1.3.x
2011.12.05 10:09 svn Checkin
2011.12.05 10:09 svn Note Added: 0005833
2011.12.05 10:09 svn Checkin
2011.12.05 10:09 svn Note Added: 0005834
2011.12.05 10:10 plg Status assigned => closed
2011.12.05 10:10 plg Resolution open => fixed
2011.12.05 10:10 plg Fixed in Version => 2.3.2


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker