Piwigo Bugtracker

Piwigo bug tracker has moved to Github

This bugtracker is kept to provide history on old issues.


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002561Piwigoalbumspublic2012.02.01 23:572012.03.23 12:17
Reporterplg 
Assigned Toplg 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3.2 
Target Version2.4.0beta2Fixed in Version2.4.0beta2 
Summary0002561: redesign on album administration screen
DescriptionInstead of a multiple form administration screen, we need to make this screen simpler, and show related screen as tabs and not as separated screens.
TagsNo tags attached.
browserany
Database engine and version
PHP version
Web serverApache 1.3.x
Attached Files

- Relationships

-  Notes
(0005981)
svn (reporter)
2012.02.02 00:03

[Subversion] r13013 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2561: redesign on album administration screen.

* only one form on the screen and several tabs

* simpler URL pattern : page=album-123-properties / page=album-123-sort_order
  / page=album-123-permissions

* action to associate all photos of an album to another (new) virtual album
  was removed. This can be easily done with the new Batch Manager

* notification by email on an album still has to be moved on a new dedicated tab

* action icons (jump to album, manage photos, manage sub-albums, delete album...)
  replaced by plain text links
(0005982)
svn (reporter)
2012.02.02 21:47

[Subversion] r13020 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2561: move some CSS rules from cat_modify.tpl to theme.css
(0005985)
rvelices (developer)
2012.02.03 19:16

- modify album link on index page is not working (warnings + fatal_error)
- edit album permission from cat_list says Undefined variable: admin_album_base_url in ...
(0005986)
svn (reporter)
2012.02.03 22:33

[Subversion] r13025 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2561: fix links on album administration screens
(0006002)
rvelices (developer)
2012.02.09 08:49

- need invalidate_user_cache on admin.php if page is album and has _POST ...
(0006006)
plg (manager)
2012.02.09 12:53

you mean that invalidate_user_cache on $page['page'] == album even without $_POST is "too much" ? this is what we had on 2.3 for cat_modify/cat_perm)
(0006007)
rvelices (developer)
2012.02.09 13:57

Let's say - if there is no need to invalidate user cache don't do it ...
I know for 2.3, but we can always do better :)
(0006008)
plg (manager)
2012.02.09 14:03

OK, I understand what you mean, I was wondering which bug I had introduced! Actually I didn't not introduced any bug with the redesign ;-) your request is not related to the graphic redesign.

If you think it's safe to only invalidate_user_cache if isset($_POST), you can apply this change.
(0006009)
rvelices (developer)
2012.02.09 16:22

it is a bug because now you have $page['page']='album' and you never call invalidate_user_cache, but it should for example when the album becomes locked or private...
I'll make the change.
(0006010)
plg (manager)
2012.02.09 16:28

in admin.php, I have:

if (
    in_array($page['page'],
      array(
        'site_manager', // delete site
        'site_update', // ?only POST
        'cat_list', // delete cat
        'album', // delete cat; public/private; lock/unlock, permissions
        'cat_move', // ?only POST
        'cat_options', // ?only POST; public/private; lock/unlock
        'picture_modify', // ?only POST; associate/dissociate
        'user_perm',
        'group_perm',
        'group_list', // delete group
      )
    )
    or ( !empty($_POST) and in_array($page['page'],
        array(
          'batch_manager', // associate/dissociate; delete; set level
          'user_list', // group assoc; user level
        )
      )
    )
  )
{
  invalidate_user_cache();
}

$page['page'] == 'album' is in the list. And on page=album-123-properties when I change from public to private, the album becomes invisible. I see no bug :-/
(0006011)
rvelices (developer)
2012.02.09 18:10

I must be blind. Really sorry to bother you !!!
(0006012)
plg (manager)
2012.02.09 18:17

No worry :-) I was really wondering what I did wrong (the redesign is not finished but I didn't plan to introduce bug on user cache)
(0006126)
svn (reporter)
2012.03.23 12:17

[Subversion] r13668 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2561: notification on album was moved to a dedicated tab on the "Edit album" screen.

- Issue History
Date Modified Username Field Change
2012.02.01 23:57 plg New Issue
2012.02.01 23:57 plg Status new => assigned
2012.02.01 23:57 plg Assigned To => plg
2012.02.01 23:57 plg browser => any
2012.02.01 23:57 plg Web server => Apache 1.3.x
2012.02.02 00:03 svn Checkin
2012.02.02 00:03 svn Note Added: 0005981
2012.02.02 00:10 plg Status assigned => closed
2012.02.02 00:10 plg Resolution open => fixed
2012.02.02 00:10 plg Fixed in Version => 2.4.0beta2
2012.02.02 21:47 svn Checkin
2012.02.02 21:47 svn Note Added: 0005982
2012.02.03 19:16 rvelices Note Added: 0005985
2012.02.03 19:16 rvelices Status closed => feedback
2012.02.03 19:16 rvelices Resolution fixed => reopened
2012.02.03 22:33 svn Checkin
2012.02.03 22:33 svn Note Added: 0005986
2012.02.05 02:07 plg Status feedback => closed
2012.02.05 02:07 plg Resolution reopened => fixed
2012.02.09 08:49 rvelices Note Added: 0006002
2012.02.09 08:49 rvelices Status closed => feedback
2012.02.09 08:49 rvelices Resolution fixed => reopened
2012.02.09 12:53 plg Note Added: 0006006
2012.02.09 13:57 rvelices Note Added: 0006007
2012.02.09 14:03 plg Note Added: 0006008
2012.02.09 16:22 rvelices Note Added: 0006009
2012.02.09 16:28 plg Note Added: 0006010
2012.02.09 18:10 rvelices Note Added: 0006011
2012.02.09 18:17 plg Note Added: 0006012
2012.02.09 19:42 rvelices Status feedback => closed
2012.02.09 19:42 rvelices Resolution reopened => fixed
2012.03.23 12:17 svn Checkin
2012.03.23 12:17 svn Note Added: 0006126


Copyright © 2000 - 2019 MantisBT Team
Contact
Powered by Mantis Bugtracker