Piwigo Bugtracker

Piwigo bug tracker has moved to Github

This bugtracker is kept to provide history on old issues.


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000026Piwigoalbumspublic2004.04.12 11:312004.07.04 23:05
Reporterplg 
Assigned Toplg 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.3.1 
Target VersionFixed in Version 
Summary0000026: wrong order of categories names
DescriptionWhen categories tree has category ids not in ascending order, the order of display still uses ids order.
Steps To ReproduceLet's give an example !

I have this tree :

Anniversaries
  |-> Pierrick 2003
  |-> Sylvain 2002
  `-> Pierrick 2002


And I want the following :

Anniversaries
  |-> 2002
  |    |-> Pierrick
  |    `-> Sylvain
  `-> 2003
       `-> Pierrick


First, I create manually categories "2002" and "2003", I move directory anniversaries/pierrick_2003 to anniversaries/2003/pierrick and update manually the id_uppercat in the database (same for pierrick_2002 and sylain_2002).

Finally, category id of "Anniversaries > 2002" is greater (because newer) than "Anniversaries > 2002 > Pierrick" and the display will be "Anniversaries > Pierrick > 2002"
TagsNo tags attached.
browserany
Database engine and version
PHP version
Web serverApache 1.3.x
Attached Files

- Relationships

-  Notes
(0000008)
plg (manager)
2004.04.30 19:07

resolved on branch 1.3

- Issue History
Date Modified Username Field Change
2004.04.12 11:31 plg New Issue
2004.04.12 11:31 plg Steps to Reproduce Updated
2004.04.12 11:32 plg Steps to Reproduce Updated
2004.04.30 19:07 plg Status assigned => resolved
2004.04.30 19:07 plg Resolution open => fixed
2004.04.30 19:07 plg Note Added: 0000008
2004.07.04 23:05 plg Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Contact
Powered by Mantis Bugtracker