Piwigo Bugtracker

Piwigo bug tracker has moved to Github

This bugtracker is kept to provide history on old issues.


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002614Piwigonavigationpublic2012.04.10 11:572012.12.04 13:47
Reporterplg 
Assigned Tomistic100 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4.3 
Target Version2.5.0beta2Fixed in Version2.5.0beta2 
Summary0002614: pagination on albums
DescriptionWe already have a pagination on thumbnails. A pagination on albums would also be useful.
TagsNo tags attached.
browserany
Database engine and version
PHP version
Web serverApache 1.3.x
Attached Files

- Relationships

-  Notes
(0006646)
svn (reporter)
2012.09.23 13:19

[Subversion] r18165 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2614: pagination on albums
(0006647)
rvelices (developer)
2012.09.24 09:02

would it be possible to retrieve category list in index.php instead of section_init ? (it will avoid unnecessary queries for picture page ...)
thanks
(0006648)
mistic100 (developer)
2012.09.24 12:42

I prefer this kind of working, more logical I think
BUT I agree tehre is one extra query, I can add if (script_basename()=='index')
(0006651)
svn (reporter)
2012.09.28 13:46

[Subversion] r18330 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
feature:2754 and feature:2614, fatal error when installing Piwigo
(0006657)
svn (reporter)
2012.10.01 15:58

[Subversion] r18392 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2614: pagination on albums, save one query on picture page
(0006658)
rvelices (developer)
2012.10.02 08:54

did you try recent albums ?
because the code looks like:
if ('categories' == $page['section'])
{
  if ( ...
    and ('recent_cats'==$page['section'] or 'categories'==$page['section'])
    and (!isset($page['category']['count_categories']) or $page['category']['count_categories']>0 )
  )
  {

obviously page[section] is always categories and never recent_cats
and I also believe $page['category']['count_categories'] is never set whatever happens ...
(0006659)
rvelices (developer)
2012.10.02 09:21

In addition, albums are not sorted anymore because page[categories] are not sorted by rank (or global rank in case of recent_cats) and you slice this array

I believe it is a lot cleaner to move all the added code from section_init/index into category_cats because
- not included if you have an album only with images (count_categories is set by menubar)
- you make a SINGLE query to get representatives, counters etc..., then you sort by rank/global_rank and apply slicing and create the navigation bar if required ...
(0006665)
svn (reporter)
2012.10.04 17:03

[Subversion] r18462 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
feature:2614 pagination on albums
return to old fashioned way (one query in category_cats), restoring recent_cats feature and "menubar optimization", rename "starta" into "startcat"
(0006668)
rvelices (developer)
2012.10.04 18:21

note: but still missing a
if ($page['section']=='recent_cats')
    uasort($categories_sql, 'global_rank_compare');
just after the hash_from_query (and remove the sort later in the code)
(0006670)
svn (reporter)
2012.10.04 18:44

[Subversion] r18464 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
feature:2614 restore global_rank on recent_cats
(0006690)
plg (manager)
2012.10.25 10:45

Can we consider this ticket as completed?
(0006694)
mistic100 (developer)
2012.10.25 10:51

yes
(0006695)
plg (manager)
2012.10.25 11:05

I've just made a few tests with a the setting "Number of albums per page" set to 4 and the first page shows 2 albums, the second 4, the third 3, the last 2 (this one is OK, the last page can have less than 4).

I prefer to reopen for now and talk about it on 2.5.0beta2
(0006699)
plg (manager)
2012.10.26 14:21

I guess the problem I have described is related to [Subversion] r18729
(0006700)
rvelices (developer)
2012.10.27 08:54

> I guess the problem I have described is related to [Subversion] r18729
This commit is purely related to the the navigation bar links. Are the links in the nav bar ok or not ? (they are on my side)
(0006701)
mistic100 (developer)
2012.10.27 11:12

that's very strange and I can't reproduce on my side.
plg is it on one of your online test galleries ? can I get an access ?
(0006702)
plg (manager)
2012.10.27 11:29

@rvelices I have tested navigation bar for thumbnails before releasing 2.5.0beta1 and it was perfectly OK

@mistic100 it was on my local dev gallery. I will give another try and tell you.
(0006720)
svn (reporter)
2012.11.02 16:04

[Subversion] r18892 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
feature:2614 bad display when there are empty albums
revert most of the previous changes and slice the array at the very end
(0006721)
plg (manager)
2012.11.02 16:16

with [Subversion] r18892 it's good for me, thank you mistic100.
(0006738)
rvelices (developer)
2012.11.13 12:30

mobile theme navigation bar is never shown now ...
(0006739)
svn (reporter)
2012.11.13 13:05

[Subversion] r19002 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
feature:2614 pagination on albums, change var name to allow redefinition
(0006740)
mistic100 (developer)
2012.11.13 13:06

SmartPocket doesn't show navbar, even for thumbnails

the previous commit will allow SmartPocket to show all albums
(0006741)
rvelices (developer)
2012.11.13 15:39

Smartpocket on pwigo.org/demo shows nav bar for thumbs. The trunk does not.
(0006742)
svn (reporter)
2012.11.13 21:12

[Subversion] r19006 by rvelices on trunk

-----[Subversion commit log]----------------------------------------------------
bug 2614: pagination on albums - fix mobile theme
(0006743)
svn (reporter)
2012.11.13 21:39

[Subversion] r19009 by mistic100 on trunk

-----[Subversion commit log]----------------------------------------------------
feature:2614 pagination on albums, disable pagination on SmartPocket, waiting for a better integration
(0006765)
svn (reporter)
2012.12.04 13:47

[Subversion] r19281 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2614: on a upgraded gallery, nb_categories_page is set to 50 instead
of the default value 12 for a new installation.

- Issue History
Date Modified Username Field Change
2012.04.10 11:57 plg New Issue
2012.04.10 11:57 plg browser => any
2012.04.10 11:57 plg Web server => Apache 1.3.x
2012.09.16 00:54 mistic100 Status new => assigned
2012.09.16 00:54 mistic100 Assigned To => mistic100
2012.09.23 13:19 svn Checkin
2012.09.23 13:19 svn Note Added: 0006646
2012.09.23 13:21 mistic100 Product Version 2.3.4 => 2.4.3
2012.09.24 09:02 rvelices Note Added: 0006647
2012.09.24 12:42 mistic100 Note Added: 0006648
2012.09.28 13:46 svn Checkin
2012.09.28 13:46 svn Note Added: 0006651
2012.10.01 15:58 svn Checkin
2012.10.01 15:58 svn Note Added: 0006657
2012.10.02 08:54 rvelices Note Added: 0006658
2012.10.02 09:21 rvelices Note Added: 0006659
2012.10.04 17:03 svn Checkin
2012.10.04 17:03 svn Note Added: 0006665
2012.10.04 18:21 rvelices Note Added: 0006668
2012.10.04 18:41 mistic100 Note Added: 0006669
2012.10.04 18:41 mistic100 Note Deleted: 0006669
2012.10.04 18:44 svn Checkin
2012.10.04 18:44 svn Note Added: 0006670
2012.10.25 10:45 plg Note Added: 0006690
2012.10.25 10:51 mistic100 Note Added: 0006694
2012.10.25 10:51 mistic100 Status assigned => closed
2012.10.25 10:51 mistic100 Resolution open => fixed
2012.10.25 10:51 mistic100 Fixed in Version => 2.5.0beta1
2012.10.25 11:05 plg Note Added: 0006695
2012.10.25 11:05 plg Status closed => assigned
2012.10.25 11:05 plg Resolution fixed => reopened
2012.10.25 11:05 plg Fixed in Version 2.5.0beta1 =>
2012.10.25 11:05 plg Target Version 2.5.0beta1 => 2.5.0beta2
2012.10.26 14:21 plg Note Added: 0006699
2012.10.27 08:54 rvelices Note Added: 0006700
2012.10.27 11:12 mistic100 Note Added: 0006701
2012.10.27 11:29 plg Note Added: 0006702
2012.11.02 16:04 svn Checkin
2012.11.02 16:04 svn Note Added: 0006720
2012.11.02 16:16 plg Note Added: 0006721
2012.11.02 23:21 plg Status assigned => closed
2012.11.02 23:21 plg Resolution reopened => fixed
2012.11.02 23:21 plg Fixed in Version => 2.5.0beta2
2012.11.13 12:30 rvelices Note Added: 0006738
2012.11.13 12:30 rvelices Status closed => feedback
2012.11.13 12:30 rvelices Resolution fixed => reopened
2012.11.13 13:05 svn Checkin
2012.11.13 13:05 svn Note Added: 0006739
2012.11.13 13:06 mistic100 Note Added: 0006740
2012.11.13 15:39 rvelices Note Added: 0006741
2012.11.13 21:12 svn Checkin
2012.11.13 21:12 svn Note Added: 0006742
2012.11.13 21:23 rvelices Status feedback => closed
2012.11.13 21:23 rvelices Resolution reopened => fixed
2012.11.13 21:39 svn Checkin
2012.11.13 21:39 svn Note Added: 0006743
2012.12.04 13:47 svn Checkin
2012.12.04 13:47 svn Note Added: 0006765


Copyright © 2000 - 2018 MantisBT Team
Contact
Powered by Mantis Bugtracker