Piwigo Bugtracker

Piwigo bug tracker has moved to Github

This bugtracker is kept to provide history on old issues.


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002771Piwigotemplatepublic2012.10.12 22:162012.11.06 22:01
Reporterrvelices 
Assigned Torvelices 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4.4 
Target Version2.5.0beta2Fixed in Version2.5.0beta2 
Summary0002771: upgrade jquery and jquery.ui
Descriptionjquery from 1.7.2 to 1.8.2
jquery.ui from 1.8.16 to 1.9.0

Attention plugins: jquery ui effect script ids change when using combine_script because file names changed ...
TagsNo tags attached.
browserany
Database engine and version
PHP version
Web serverApache 1.3.x
Attached Files

- Relationships

-  Notes
(0006678)
svn (reporter)
2012.10.12 22:32

[Subversion] r18630 by rvelices on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2771: upgrade jquery from 1.7.2 to 1.8.2 and jquery.ui from 1.8.16 to 1.9.0
Attention plugins: jquery ui effect script ids change when using combine_script because file names changed ...
(0006687)
mistic100 (developer)
2012.10.21 17:37

was it really necessary to change the names ? it's a mess in many plugins now

(I don't know if files are loaded by Piwigo or by JQ UI itself)
(0006688)
rvelices (developer)
2012.10.22 07:33

ids changed because the file names changed in jquery ui. and id-file name mapping is automatic.

we could provide backward compatibility by automatically changnd id and require parameters from old ids to new ids
(0006707)
mistic100 (developer)
2012.10.28 21:17

that would better
(0006708)
rvelices (developer)
2012.10.28 21:32

which plugin uses it so that I can quickly test my changes ...
(0006709)
mistic100 (developer)
2012.10.28 21:39

I get warnings with Stripped
and on the admin page of Gthumb+ (when generating thumbnails)
for example
(0006710)
svn (reporter)
2012.10.28 22:25

[Subversion] r18775 by rvelices on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2771: added backward compatibility with pre jquery ui 1.9 effect file naming (combine script id issues)
(0006723)
svn (reporter)
2012.11.06 22:01

[Subversion] r18953 by rvelices on trunk

-----[Subversion commit log]----------------------------------------------------
feature 2771 upgrade jquery ui - forgot to add non minimified files (not used anywhere in the code, but for the sake of coherence)

- Issue History
Date Modified Username Field Change
2012.10.12 22:16 rvelices New Issue
2012.10.12 22:16 rvelices Status new => assigned
2012.10.12 22:16 rvelices Assigned To => rvelices
2012.10.12 22:16 rvelices browser => any
2012.10.12 22:16 rvelices Web server => Apache 1.3.x
2012.10.12 22:32 svn Checkin
2012.10.12 22:32 svn Note Added: 0006678
2012.10.13 17:40 rvelices Status assigned => closed
2012.10.13 17:40 rvelices Resolution open => fixed
2012.10.13 17:40 rvelices Fixed in Version => 2.5.0beta1
2012.10.21 17:37 mistic100 Note Added: 0006687
2012.10.21 17:37 mistic100 Status closed => feedback
2012.10.21 17:37 mistic100 Resolution fixed => reopened
2012.10.22 07:33 rvelices Note Added: 0006688
2012.10.25 10:42 plg Fixed in Version 2.5.0beta1 =>
2012.10.25 10:42 plg Target Version 2.5.0beta1 => 2.5.0beta2
2012.10.28 21:17 mistic100 Note Added: 0006707
2012.10.28 21:32 rvelices Note Added: 0006708
2012.10.28 21:39 mistic100 Note Added: 0006709
2012.10.28 22:25 svn Checkin
2012.10.28 22:25 svn Note Added: 0006710
2012.11.06 10:13 plg Status feedback => closed
2012.11.06 10:13 plg Resolution reopened => fixed
2012.11.06 10:13 plg Fixed in Version => 2.5.0beta2
2012.11.06 22:01 svn Checkin
2012.11.06 22:01 svn Note Added: 0006723


Copyright © 2000 - 2019 MantisBT Team
Contact
Powered by Mantis Bugtracker