Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000287 [Piwigo] configuration block always 2006.02.13 11:21 2009.08.08 18:56
Reporter benz View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.0 Product Version 1.5.2
  Target Version Product Build
Summary 0000287: Admin access - error
Description Hi,

Here is what i find when i try to go in admin. i didnt touch anything.
and now im stuck with it :)

INSERT INTO phpwebgallery_user_infos
  (user_id,status,template,nb_image_line,nb_line_page,language,recent_period,expand,show_nb_comments,maxwidth,maxheight,registration_date)
   VALUES
  ('47','guest','yoga-dark',NULL,NULL,'en_UK.iso-8859-1','30','true','true',NULL,NULL,'2006-02-11 00:01:27')
;
[mysql error 1048] Column 'nb_image_line' cannot be null


qu'a t(il pu se passer? j'ai essayé sous IE sous FF etc..

thanks for your help
Steps To Reproduce
Additional Information
Tags No tags attached.
browser Mozilla
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
related to 0000406closed Error when accessing to "Administration" 

-  Notes
(0000632)
plg (manager)
2006.02.13 20:30

Can you execute the following SQL queries in your database manager :

UPDATE phpwebgallery_config
  SET value = '5'
  WHERE param = 'nb_image_line'
;

UPDATE phpwebgallery_config
  SET value = '3'
  WHERE param = 'nb_line_page'
;

Go back to your administration panel, problem should have disappeared.

The bug is that configuration screen lets you set empty values for those two fields.
(0000642)
nikrou (developer)
2006.02.15 20:43

fixed in trunk [Subversion] r1043
(0000643)
plg (manager)
2006.02.15 20:52
edited on: 2006.02.15 20:53

[Subversion] r1043 does not fix the bug. The problem comes from default values set in admin/configuration.php.

Why did you try to fix in the trunk ? it should be fixed in branch 1.5 and correction reported to trunk.

Isn't this bug assigned to me ? (I was waiting for benz's feedback)

(0000644)
nikrou (developer)
2006.02.15 21:52

My commit doesn' completly fix the bug. There's a problem in profile.php that I fix and a problem in admin that i didn't fix.

> Why did you try to fix in the trunk ?

mistake.

> Isn't this bug assigned to me ? (I was waiting for benz's feedback)

make a revert and fix it as you want
(0000647)
plg (manager)
2006.02.16 21:04

> make a revert and fix it as you want

I hope you don't take it bad (j'espère que tu ne le prends pas mal), but if we start to work on bugs already assigned to others, there is a big risk that the same work is made twice.
(0002805)
mathiasm (manager)
2009.08.08 18:56

I think it can be closed. Reopen if not.

- Issue History
Date Modified Username Field Change
2006.02.13 11:21 benz New Issue
2006.02.13 11:21 benz browser => Mozilla
2006.02.13 11:21 benz Web server => Apache 1.3.x
2006.02.13 19:28 plg Assigned To => plg
2006.02.13 19:28 plg Reproducibility unable to reproduce => always
2006.02.13 19:28 plg Status new => assigned
2006.02.13 19:28 plg Category other => configuration
2006.02.13 20:30 plg Note Added: 0000632
2006.02.13 20:31 plg Status assigned => feedback
2006.02.15 20:43 nikrou Note Added: 0000642
2006.02.15 20:45 nikrou Status feedback => resolved
2006.02.15 20:45 nikrou Fixed in Version => BSF branch (dev)
2006.02.15 20:45 nikrou Resolution open => fixed
2006.02.15 20:52 plg Note Added: 0000643
2006.02.15 20:52 plg Status resolved => assigned
2006.02.15 20:52 plg Resolution fixed => reopened
2006.02.15 20:52 plg Fixed in Version BSF branch (dev) =>
2006.02.15 20:53 plg Note Edited: 0000643
2006.02.15 21:52 nikrou Note Added: 0000644
2006.02.16 21:04 plg Note Added: 0000647
2006.06.08 14:09 plg Relationship added related to 0000406
2009.08.08 18:56 mathiasm Note Added: 0002805
2009.08.08 18:56 mathiasm Status assigned => closed
2009.08.08 18:56 mathiasm Resolution reopened => fixed
2009.08.08 18:56 mathiasm Fixed in Version => 2.0.0


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker