Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000031 [Piwigo] albums feature always 2004.06.05 12:01 2005.05.01 10:58
Reporter rych View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.4 branch Product Version
  Target Version Product Build
Summary 0000031: Calendar category
Description Year-month-day categories better to be displayed in a calendar DHTML widget rather than in a tree.

Suggested solution.
If the name of a category contains "calendar", assume its subcategory tree is year/months/days; invoke an alternative version of display_category() that will populate an alternative VTP_category section with DHTML calendar along with the JavaScript data -- arrays of non-empty years, months, and days to be linked to the terminal day-categories.

Examples of available DHTML calendars.
* http://www.dynamicdrive.com/dynamicindex6/dcalendar.htm [^]
working; Prev. and Next should be replaced with arrows and direct to non-empty years or months;
* http://www.dansteinman.com/dynduo/en/calendar.html [^]
seems not working, but good colors.

Please tell if you'd take up implementing this soon. Otherwise, I will have to do it, because my photo-tree is growing rapidly.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0000010)
plg (manager)
2004.06.05 12:30

OK, I'm already working on it since I've found your idea great ! Hiw do I see the feature : calendar is a special category (like X most seen, or recent pictures). No tree in categories menu, but 2 navigation bar displayed : years and months. For each month, display of a picture per day when pictures were made available. If you click on a day, it's like searching all pictures added on the date.
(0000011)
rych (reporter)
2004.06.06 06:37

Thank you! I look forward to seeing it so much. The adding date should be a searchable category, indeed. I hope it can have a parent category so that to give all the items added to the _parent_ and not to the whole gallery.

Meanwhile, I've come to realise that a DHTML calendar representation of a year-month-day folder tree may be needed for other catalogs I have as well. There appears to be the most elaborate one, "The Coolest DHTML Calendar" (http://dynarch.com/mishoo/calendar/). [^] For example, through callback function it can dispaly "special days" with special style. I will be playing with it.

Thanks again, and keep us posted
(0000012)
plg (manager)
2004.06.06 08:36

> I hope it can have a parent category so that to give all the items added
> to the _parent_ and not to the whole gallery.

what do you mean exactly ?

For the moment, the feature exists as I imagined it. There is no "year-month-day" tree in the categegories menu, but I might be a good idea, I think I'll add it too.

I've decided to only show calendar element (years, months, days) that have pictures, not the other ones. If the 2004-06-06 has no new picture, it won't be shown in calendar.
(0000013)
rych (reporter)
2004.06.07 07:34

>> I hope it can have a parent category so that to give all the items added
>> to the _parent_ and not to the whole gallery.
>
> what do you mean exactly ?
Will clicking on a non-empty day search all pictures added on the day to some _selected_ category or the search will be over the whole gallery?
(0000014)
plg (manager)
2004.06.07 15:22

> Will clicking on a non-empty day search all pictures added on the day to
> some _selected_ category or the search will be over the whole gallery ?

How would it be possible to search only in some selected categories ? Of course it is over the wholme gallery (depending on the connected user, you have permissions...)
(0000015)
plg (manager)
2004.06.08 00:19

In fact, I might understant what you mean... What do you think of this suggestion :

 1. click on the special category "calendar" : you enter in a category with 2 navigation bars, the first one is the years, the second is the months of the selected year. Only years and months with pictures available are shown.

 2. choose a year. By default the last year is selected. In the menu, under the special category "calendar", a tree appear, with only years. In the thumbnails table, a thumbnail (random) is chosen to represent each month.

 3. choose a month : each day of this month is represented by a random picture. In the menu, each day of the month is shown.

 4. choose a day : now you have a list of categories where pictures were added this day, and in bonus a special category, a non-category in fact, were pictures are not owned by a category in particular.

 5. choose a category : all pictures of this category of this day are shown. If the special "non-category" is selected, all pictures of this day are shown.

Your feeling ?
(0000016)
rych (reporter)
2004.06.08 11:38
edited on: 2004.06.08 11:40

Yes I think that's the right way to do date-searching!

Let me just mention why I was thinking about a DHTML calendar. That's just another view on a date-based gallery. Suppose one adds his photos to year-month-days folders and has the option expand_all; then the category menu would become rather long, listing all those (non-empty) years, months and days. The DHTML calendar would be just a neater way to _show_ it.

You have solved a more general task, actually. So thanks a lot, and please show off the example when it's ready!

edited on: 2004.06.08 11:38
(0000023)
plg (manager)
2004.08.24 21:52

This feature is partly present in actual development branch snapshots. You can test it and report your feelings (please :-)
(0000047)
plg (manager)
2004.10.23 11:09

available in dev snapshot since 2004-08-07

- Issue History
Date Modified Username Field Change
2004.06.05 12:01 rych New Issue
2004.06.05 12:30 plg Note Added: 0000010
2004.06.05 12:30 plg Assigned To => plg
2004.06.05 12:30 plg Status new => acknowledged
2004.06.05 12:30 plg Category display => category management
2004.06.05 12:30 plg version 1.3.2 => 1.4
2004.06.06 06:37 rych Note Added: 0000011
2004.06.06 08:36 plg Note Added: 0000012
2004.06.06 08:37 plg Status acknowledged => assigned
2004.06.07 07:34 rych Note Added: 0000013
2004.06.07 15:22 plg Note Added: 0000014
2004.06.08 00:19 plg Note Added: 0000015
2004.06.08 11:38 rych Note Added: 0000016
2004.06.08 11:40 rych Note Edited: 0000016
2004.08.24 21:52 plg Note Added: 0000023
2004.10.23 11:09 plg Status assigned => resolved
2004.10.23 11:09 plg Resolution open => fixed
2004.10.23 11:09 plg Note Added: 0000047
2005.01.17 13:24 plg Status resolved => closed
2005.01.17 13:24 plg Fixed in Version => 1.4
2005.05.01 10:58 plg version 1.4 branch =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker