Piwigo Bugtracker

Piwigo bug tracker has moved to Github

This bugtracker is kept to provide history on old issues.


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003126Piwigoalbumspublic2014.08.24 22:522014.10.09 21:37
Reporterflop25 
Assigned Toflop25 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version2.7.0RC2Fixed in Version2.7.1 
Summary0003126: can apply Is Commentable on sub albums
Descriptionfrom the edition page of an album, set sub albums as commentable on demand
TagsNo tags attached.
browserany
Database engine and version
PHP version
Web serverApache 1.3.x
Attached Files

- Relationships

-  Notes
(0007595)
svn (reporter)
2014.08.24 22:56

[Subversion] r29265 by flop25 on trunk

-----[Subversion commit log]----------------------------------------------------
feature:3126
Apply on subalbum checkbox about comments
(0007651)
rvelices (developer)
2014.10.01 06:50

I get a warning
PHP Notice: Undefined index: apply_commentable_on_sub
(0007654)
svn (reporter)
2014.10.01 19:59

[Subversion] r29857 by flop25 on trunk

-----[Subversion commit log]----------------------------------------------------
feature:3126 no more notice should be displayed
thx to rvelices for the report!
(0007655)
svn (reporter)
2014.10.01 20:06

[Subversion] r29858 by flop25 on branch 2.7

-----[Subversion commit log]----------------------------------------------------
Merged revision(s) 29857 from trunk/admin:
feature:3126 no more notice should be displayed
thx to rvelices for the report!

(0007660)
rvelices (developer)
2014.10.03 19:32

I think the issue is still there because the if expression is evaluated left to right so the first part will produce the warning anyway (I did not test but I believe so).

Did you test your change ?

I think just
if (isset($_POST['apply_commentable_on_sub']))

is enough.
(0007662)
flop25 (developer)
2014.10.03 21:20

Sry! I couldn't reproduce; error_reporting issues for sure on my config
indeed just an isset should be enough Will check then commit soon Thx again
(0007673)
svn (reporter)
2014.10.09 21:34

[Subversion] r29949 by flop25 on trunk

-----[Subversion commit log]----------------------------------------------------
bug:3126
just an isset
(0007674)
svn (reporter)
2014.10.09 21:35

[Subversion] r29950 by flop25 on branch 2.7

-----[Subversion commit log]----------------------------------------------------
Merged revision(s) 29949 from trunk:
bug:3126
just an isset

- Issue History
Date Modified Username Field Change
2014.08.24 22:52 flop25 New Issue
2014.08.24 22:52 flop25 Status new => assigned
2014.08.24 22:52 flop25 Assigned To => flop25
2014.08.24 22:52 flop25 browser => any
2014.08.24 22:52 flop25 Web server => Apache 1.3.x
2014.08.24 22:56 svn Checkin
2014.08.24 22:56 svn Note Added: 0007595
2014.08.24 23:04 flop25 Status assigned => closed
2014.08.24 23:04 flop25 Resolution open => fixed
2014.08.24 23:04 flop25 Fixed in Version => 2.7.0RC2
2014.10.01 06:50 rvelices Note Added: 0007651
2014.10.01 06:50 rvelices Status closed => feedback
2014.10.01 06:50 rvelices Resolution fixed => reopened
2014.10.01 19:59 svn Checkin
2014.10.01 19:59 svn Note Added: 0007654
2014.10.01 20:06 svn Checkin
2014.10.01 20:06 svn Note Added: 0007655
2014.10.01 21:02 flop25 Status feedback => closed
2014.10.01 21:02 flop25 Resolution reopened => fixed
2014.10.01 21:02 flop25 Fixed in Version 2.7.0RC2 => 2.7.1
2014.10.03 19:32 rvelices Note Added: 0007660
2014.10.03 19:32 rvelices Status closed => feedback
2014.10.03 19:32 rvelices Resolution fixed => reopened
2014.10.03 21:20 flop25 Note Added: 0007662
2014.10.09 21:34 svn Checkin
2014.10.09 21:34 svn Note Added: 0007673
2014.10.09 21:35 svn Checkin
2014.10.09 21:35 svn Note Added: 0007674
2014.10.09 21:37 flop25 Status feedback => closed
2014.10.09 21:37 flop25 Resolution reopened => fixed


Copyright © 2000 - 2017 MantisBT Team
Contact
Powered by Mantis Bugtracker