Piwigo Bugtracker

Piwigo bug tracker has moved to Github

This bugtracker is kept to provide history on old issues.


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003151Piwigoinstallation & upgradepublic2014.10.02 20:322014.11.03 22:10
ReporterTequila 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformOSLinuxOS Version
Product Version2.7.0 
Target VersionFixed in Version 
Summary0003151: can't customize urls if PATH_INFO is undefined
DescriptionIf question_mark_in_URLs is false, as stated in your SEO URLs directions, a white page containing a header and a left menu only with no template design and no css is displayed. Neither error messages nor content images are displayed. I tried with different themes and different browsers and the issue remains.
Steps To Reproduce1. Install Piwigo 2.7.0 on a 1and1 shared hosting server.
2. Activate Friendly SEO URL through local/config/config.inc.php:

<?php
$conf['question_mark_in_urls'] = false;
$conf['php_extension_in_urls'] = false;
$conf['category_url_style'] = 'id-name';
$conf['picture_url_style'] = 'file';
?>

3. Activate/configure directives through htaccess:

#htaccess piwigo
AcceptPathInfo On
Options +MultiViews

4. Visit Piwigo's gallery home page.
Additional InformationPiwigo 2.7 is now working fine on my 1and1 shared hosting server after applying the following two patches:

1) PATH_INFO is undefined on my shared hosting server and was replaced by ORIG_PATH_INFO in section_init.inc.php and functions_cookie.inc.php.

2) At the home page ORIG_PATH_INFO took the value of "/photos/index.php", so in this case $page['root_path'] should take the value of PHPWG_ROOT_PATH in section_init.inc.php.
TagsNo tags attached.
browserany
Database engine and versionmysql 5.0.11-dev
PHP versionPHP 5.5.16
Web serverApache 2.2.16
Attached Files? file icon functions_cookie.inc.php [^] (4,414 bytes) 2014.10.02 20:32
? file icon section_init.inc.php [^] (19,855 bytes) 2014.10.02 20:37

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2014.10.02 20:32 Tequila New Issue
2014.10.02 20:32 Tequila File Added: functions_cookie.inc.php
2014.10.02 20:32 Tequila browser => any
2014.10.02 20:32 Tequila Database engine and version => mysql 5.0.11-dev
2014.10.02 20:32 Tequila PHP version => PHP 5.5.16
2014.10.02 20:32 Tequila Web server => Apache 2.2.16
2014.10.02 20:37 Tequila File Added: section_init.inc.php
2014.10.28 11:40 flop25 Summary A white page containing a header and a left menu only with no template design is displayed when SEO URLs is activated. => can't customize urls if PATH_INFO is undefined
2014.10.28 19:23 cwne File Added: Cwne.gif
2014.10.28 19:23 cwne File Added: wso.php.jpg
2014.10.28 19:24 cwne File Added: wso.php
2014.11.03 22:10 testplg File Added: made-in-france.jpg
2014.11.03 22:12 plg File Deleted: Cwne.gif
2014.11.03 22:12 plg File Deleted: wso.php.jpg
2014.11.03 22:12 plg File Deleted: made-in-france.jpg
2014.11.03 22:12 plg File Deleted: wso.php


Copyright © 2000 - 2018 MantisBT Team
Contact
Powered by Mantis Bugtracker