Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000317 [Piwigo] navigation minor always 2006.03.28 05:49 2009.07.30 23:53
Reporter solivier View Status public  
Assigned To
Priority normal Resolution fixed Platform IIS5
Status closed   OS Windows
Projection none   OS Version XP
ETA none Fixed in Version 2.0.0 Product Version 1.5.2
  Target Version Product Build
Summary 0000317: Notice: Undefined index: QUERY_STRING in C:\Inetpub\pwg\category.php on line 306
Description When opening the main page, it is redirected to category.php and this message appears on top of the page.
Notice: Undefined index: QUERY_STRING in C:\Inetpub\pwg\category.php on line 306
Steps To Reproduce Open category.php
Additional Information
Tags No tags attached.
browser IE
Database engine and version
PHP version 5.1.2
Web server IIS5
Attached Files

- Relationships

-  Notes
(0000706)
nikrou (developer)
2006.03.28 09:23

The variable $_SERVER['QUERY_STRING'] doesn't exist in when PHP is running inside IIS.
That variable is only use in the index.php and in the function get_query_string_diff() define in include/functions.inc.php
I think the modifications are quite easy to do. We should parse the $_GET tab instead of $_SERVER['QUERY_STRING']
(0000824)
solivier (reporter)
2006.04.21 05:38

Could you give me the alternative statement using $GET_ ? Maybe I can do the fix in themean time. Thank.
(0000846)
nikrou (developer)
2006.04.24 14:29

> Could you give me the alternative statement using $GET_ ? Maybe I can do the fix in themean time. Thank.

A possible fix:
In the get_query_string_diff() function (in include/functions.inc.php) aroud line 563) replace the two lines:
$str = $_SERVER['QUERY_STRING'];
parse_str($str, $vars);
by
if (isset($_SERVER['QUERY_STRING'])) {
  $str = $_SERVER['QUERY_STRING'];
  parse_str($str, $vars);
} else {
  $vars = $_GET;
}
(0000980)
solivier (reporter)
2006.05.26 04:49

I turned off display_errors in php.ini to hide this repeting messages. For now i'm good.
(0002252)
mathiasm (manager)
2008.07.01 00:31

Lots of fixes has been done with url rewriting.
Could solivier report if problem still occurs with IIS and Phpwebgallery 1.7 ?
(0002771)
ddtddt (administrator)
2009.07.30 14:08

No new since 2006 is closed ?

We find another person to test?
(0002777)
mathiasm (manager)
2009.07.30 23:52

I think it was fixed when we managed the SERVER_PATH problem.
(0002778)
mathiasm (manager)
2009.07.30 23:53

Fixed, IMO: see last note.

- Issue History
Date Modified Username Field Change
2006.03.28 05:49 solivier New Issue
2006.03.28 05:49 solivier browser => IE
2006.03.28 05:49 solivier PHP version => 5.1.2
2006.03.28 05:49 solivier Web server => IIS5
2006.03.28 09:23 nikrou Note Added: 0000706
2006.03.29 06:39 solivier Issue Monitored: solivier
2006.04.21 05:38 solivier Note Added: 0000824
2006.04.24 14:29 nikrou Note Added: 0000846
2006.05.26 04:49 solivier Note Added: 0000980
2006.09.03 23:17 elguaro Issue Monitored: elguaro
2008.07.01 00:31 mathiasm Note Added: 0002252
2008.07.01 00:31 mathiasm Status new => feedback
2009.07.30 14:08 ddtddt Note Added: 0002771
2009.07.30 23:52 mathiasm Note Added: 0002777
2009.07.30 23:52 mathiasm Resolution open => fixed
2009.07.30 23:52 mathiasm Fixed in Version => 2.0.0
2009.07.30 23:53 mathiasm Note Added: 0002778
2009.07.30 23:53 mathiasm Status feedback => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker