Piwigo Bugtracker

Piwigo bug tracker has moved to Github

This bugtracker is kept to provide history on old issues.


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003230Piwigoconfigurationpublic2015.07.07 22:562015.07.07 22:56
Reportermontuno 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version2.7.4 
Target VersionFixed in Version 
Summary0003230: Theme switch / Admin tools madness or conflict
DescriptionHi,
Here is a strange issue,

When I activate admin tools plugin while running SimpleNG theme, I observe that I cannot switch to another theme afterward - meaning whatever the theme I choose the front gallery remains stuck on SimpleNG theme.

On the top of that - lets say the said 'active' theme is 'dark' in the UI and the admin tools plugin is still activated (remind, the front gallery still stuck on SimpleNG). Now if I deactivate SimpleNG theme nothing more happen (still stuck of simpleNG), however if I DELETE simpleNG theme I got the error:


Warning: include(/themeconf.inc.php): failed to open stream: No such file or directory in /srv/www/piwigo/include/template.class.php on line 1156

Warning: include(): Failed opening '/themeconf.inc.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /srv/www/piwigo/include/template.class.php on line 1156

Fatal error: Uncaught exception 'SmartyException' with message 'Unable to load template file 'menubar.tpl'' in /srv/www/piwigo/include/smarty/libs/sysplugins/smarty_internal_templatebase.php:127 Stack trace: #0 /srv/www/piwigo/include/template.class.php(484): Smarty_Internal_TemplateBase->fetch('menubar.tpl') 0000001 /srv/www/piwigo/include/template.class.php(407): Template->parse('menubar', true) 0000002 /srv/www/piwigo/include/block.class.php(205): Template->assign_var_from_handle('MENUBAR', 'menubar') 0000003 /srv/www/piwigo/include/menubar.inc.php(337): BlockManager->apply('MENUBAR', 'menubar.tpl') 0000004 /srv/www/piwigo/include/menubar.inc.php(30): initialize_menu() 0000005 /srv/www/piwigo/index.php(120): include('/srv/www/piwigo...') #6 {main} thrown in /srv/www/piwigo/include/smarty/libs/sysplugins/smarty_internal_templatebase.php on line 127

IF now, I try to deactivate admin tools : bingo the active theme in the UI (eg : 'dark') comes effective.

Could you help me to understand what is the problem here ?


TagsNo tags attached.
browserany
Database engine and version
PHP version
Web serverApache 1.3.x
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2015.07.07 22:56 montuno New Issue


Copyright © 2000 - 2017 MantisBT Team
Contact
Powered by Mantis Bugtracker