Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000335 [Piwigo] synchronization major always 2006.04.16 11:16 2006.04.19 01:37
Reporter chrisaga View Status public  
Assigned To rvelices
Priority high Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6 branch Product Version 1.6 branch
  Target Version Product Build
Summary 0000335: Regression in pwg_high (high res pictures)
Description has_high is now set during file metadata synchronization.
It shouldn't because :

1) It hardly makes sence since it's more a matter of "files structure synchronization"

2) More important, you can't add the high res. picture after the first synchronization, unless you process even already synchronized elements which is most of times what you don't want because it alters your manualy edited data.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0000761)
rvelices (developer)
2006.04.17 15:06

This feature is useful for the remote sites (checking the existence of the high picture wa slow).

I agree that for local sites ONLY it could check for the existence of the file. Tell me if local sites only is ok with you and I'll do it.
(0000762)
chrisaga (developer)
2006.04.17 15:18

I understand the feature, but the issue is the same with local and remote sites.

Why couldn't we do it while synchronizing file structure rather than metadata.

The information is actualy in the file structure, not in any metadata stored in the image itself.

This would solve the problem and make more sense for the user.

At first, It though that pwg_high handling was totaly broken. The idea of trying metadata synchronization wasn't my firs one.
(0000763)
rvelices (developer)
2006.04.17 16:01

The reason is how the code was structured in site_update.php (previously update.php). Directory/files synchronization performs only mass insert/delete in/from database.
It is the same thing for filesize which was not updated in 1.5 during directory synchronization.

I think this would be pretty much work for not a lot.
(0000764)
chrisaga (developer)
2006.04.18 08:31

1) I think it wouldn't be that much work : we already scan the whole filesystem to find new or missing files to update the database.
When we find a "whatever/picture.ext" we could probe for a "whatever/pwg_high/picture.ext" and prepare a mass_update.

2) This feature is important : people must be able to add a high-res pictures when they want without loosing their data. The only other way is to implement a metadata synchronization that doesn't erase user edited data or that synchronize these data back to the image file. I think THAT would be pretty much work.
(0000765)
plg (manager)
2006.04.18 10:51

Basicaly, I agree with chrisaga, pwg_high should not be a metadata synchronization process but a filesystem structure synchronization process.
(0000769)
rvelices (developer)
2006.04.18 13:59

I also agree. As it should be the thumbnail extension, representative extension and file size.
(0000770)
plg (manager)
2006.04.18 15:34

rvelices, file size is metadata, not filesystem synchronization.
(0000780)
rvelices (developer)
2006.04.19 01:37

[Subversion] r1203 and [Subversion] r1204

- Issue History
Date Modified Username Field Change
2006.04.16 11:16 chrisaga New Issue
2006.04.16 11:16 chrisaga browser => any
2006.04.16 11:16 chrisaga Web server => Apache 1.3.x
2006.04.17 15:06 rvelices Note Added: 0000761
2006.04.17 15:06 rvelices Status new => feedback
2006.04.17 15:18 chrisaga Note Added: 0000762
2006.04.17 16:01 rvelices Note Added: 0000763
2006.04.18 08:31 chrisaga Note Added: 0000764
2006.04.18 10:51 plg Note Added: 0000765
2006.04.18 13:59 rvelices Note Added: 0000769
2006.04.18 14:12 rvelices Status feedback => confirmed
2006.04.18 15:34 plg Note Added: 0000770
2006.04.18 16:10 rvelices Status confirmed => assigned
2006.04.18 16:10 rvelices Assigned To => rvelices
2006.04.19 01:37 rvelices Note Added: 0000780
2006.04.19 01:37 rvelices Status assigned => closed
2006.04.19 01:37 rvelices Resolution open => fixed
2006.04.19 01:37 rvelices Fixed in Version => 1.6 branch


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker