Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000344 [Piwigo] other block always 2006.04.20 19:27 2006.04.21 04:06
Reporter chrisaga View Status public  
Assigned To rvelices
Priority urgent Resolution fixed Platform Club-Internet
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6 branch Product Version 1.6 branch
  Target Version Product Build svn:1219
Summary 0000344: PWG crashes after the first synchronization
Description PWG crashes permanently after the first files+folders synchro

Might be related to bug 340
Steps To Reproduce Install PWG (with a modified install.php see bug 343)
Log in
Go to admin and synchronize files+folders

Click on whatever link you want and then enjoy the following error mesages
Additional Information Warning: array_merge() [function.array-merge]: Argument 0000001 is not an array in /photo/include/functions_user.inc.php on line 162

Warning: Invalid argument supplied for foreach() in /photo/include/functions_user.inc.php on line 164

Warning: main(./template//theme//themeconf.inc.php) [function.main]: failed to open stream: No such file or directory in /photo/include/common.inc.php on line 234

Warning: main() [function.include]: Failed opening './template//theme//themeconf.inc.php' for inclusion (include_path='.:/include') in /photo/include/common.inc.php on line 234
You are not authorized to access the requested page
Identification Home
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
duplicate of 0000308closednikrou Pb sur _sessions et _user_access 

-  Notes
(0000799)
chrisaga (developer)
2006.04.20 19:29
edited on: 2006.04.20 19:45

If you try to go back to the index page, you get :

Warning: array_merge() [function.array-merge]: Argument 0000001 is not an array in /photo/include/functions_user.inc.php on line 162

Warning: Invalid argument supplied for foreach() in /photo/include/functions_user.inc.php on line 164

SELECT cat_id
  FROM phpwebgallery_user_access
  WHERE user_id =
;
[mysql error 1064] Erreur de syntaxe près de '' à la ligne 3

==========================================================
IMHO it's definitively related to bug 340 because if you delete your session cookie, PWG is back alive untill the next synchro

(0000820)
rvelices (developer)
2006.04.21 01:27

This is rather bery similar to 308. The user_id from the cookie is broken (as in 308)
(0000823)
rvelices (developer)
2006.04.21 04:06

Here is the issue: php.ini register_globals is On at free and Club Internet which means a global variable $id and $_SESSION['id'] are exactly the same (see http://www.php.net/manual/en/security.globals.php [^] ).

There are $id global variables in site_update and comments. I chose to change SESSION['id'] to SESSION['pwg_uid'] as $id will be likely used also in the future.
There might be some other cases for example with _GET or _POST variables. Maybe we should put everything inside functions and not write code anymore at the top level.

- Issue History
Date Modified Username Field Change
2006.04.20 19:27 chrisaga New Issue
2006.04.20 19:27 chrisaga browser => any
2006.04.20 19:27 chrisaga Web server => Apache 1.3.x
2006.04.20 19:29 chrisaga Note Added: 0000799
2006.04.20 19:30 chrisaga Description Updated
2006.04.20 19:30 chrisaga Additional Information Updated
2006.04.20 19:45 chrisaga Note Edited: 0000799
2006.04.20 19:45 chrisaga Relationship added related to 0000340
2006.04.20 19:57 chrisaga Relationship added related to 0000345
2006.04.21 01:27 rvelices Note Added: 0000820
2006.04.21 01:27 rvelices Relationship added related to 0000308
2006.04.21 03:56 rvelices Relationship deleted related to 0000340
2006.04.21 03:56 rvelices Relationship deleted related to 0000345
2006.04.21 03:56 rvelices Relationship replaced duplicate of 0000308
2006.04.21 04:06 rvelices Note Added: 0000823
2006.04.21 04:06 rvelices Assigned To => rvelices
2006.04.21 04:06 rvelices Status new => closed
2006.04.21 04:06 rvelices Resolution open => fixed
2006.04.21 04:06 rvelices Fixed in Version => 1.6 branch


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker