Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000359 [Piwigo] other minor always 2006.04.27 19:12 2006.04.29 18:14
Reporter rvelices View Status public  
Assigned To rvelices
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6.0RC2 Product Version 1.6.0RC1
  Target Version Product Build
Summary 0000359: Anonymous rating links hit by search engines
Description Yahoo (and maybe others) does not respect the rel="nofollow" attribute for rating pictures links (so the crawler rates the pictures itself).

Something different should be done (like Javascript) instead of plain links.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0000874)
chrisaga (developer)
2006.04.27 20:03

<:o))
(0000875)
plg (manager)
2006.04.27 20:06

(I don't like Javascript very much.) Wouldn't it be a solution to have a form with N checkboxes and a submit "Rate" button?
(0000879)
rvelices (developer)
2006.04.27 22:36

I'll figure out something that works nice with JS (select with no button) and is also working without JS (select with Rate button)
(0000881)
plg (manager)
2006.04.27 23:02

rvelices, do you really like select box without submit button? I personnaly don't :-/ This is not accessible. I sometimes goes from field to field in a form with the tab key, and I really hate when it submits magicaly only because I passed on the "auto submit" select box.

When we have very few options and that option labels are short (like for rating), isn't it better to use checkbox/radio instead of select?
(0000887)
rvelices (developer)
2006.04.28 00:39

>I really hate when it submits magicaly
Personally I like it. Why do 2 clicks when you can do one?
But I'll do it your way (with radios because checkboxes cannot be mutually exclusive).
As at any given time, one radio must be selected, what whould be the default when the user didn't rate the picture yet ? Middle element of the array ?
(0000888)
rvelices (developer)
2006.04.28 04:18

Or maybe event better: a small form with five buttons ! That's one click and no Javascript
(0000891)
plg (manager)
2006.04.28 10:10

rvelices wrote:

> Or maybe event better: a small form with five buttons !

great :-)

- Issue History
Date Modified Username Field Change
2006.04.27 19:12 rvelices New Issue
2006.04.27 19:12 rvelices browser => any
2006.04.27 19:12 rvelices Web server => Apache 1.3.x
2006.04.27 20:03 chrisaga Note Added: 0000874
2006.04.27 20:06 plg Note Added: 0000875
2006.04.27 22:36 rvelices Note Added: 0000879
2006.04.27 23:02 plg Note Added: 0000881
2006.04.28 00:39 rvelices Note Added: 0000887
2006.04.28 04:18 rvelices Note Added: 0000888
2006.04.28 04:18 rvelices Assigned To => rvelices
2006.04.28 04:18 rvelices Status new => assigned
2006.04.28 10:10 plg Note Added: 0000891
2006.04.29 18:14 rvelices Status assigned => closed
2006.04.29 18:14 rvelices Resolution open => fixed
2006.04.29 18:14 rvelices Fixed in Version => 1.6.0RC2


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker